Bug 23245 - gcc 4.0.1 unable to build glibc 2.3.5 - 'isinf' aliased to undefined symbol '__isinf'
Summary: gcc 4.0.1 unable to build glibc 2.3.5 - 'isinf' aliased to undefined symbol '...
Status: RESOLVED DUPLICATE of bug 20652
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.0.1
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-05 09:05 UTC by ray
Modified: 2005-08-05 15:27 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ray 2005-08-05 09:05:21 UTC
building glibc-2.3.5 on ix86 linux with gcc 4.0.1 fails complaining that

    'isinf' aliased to undefined symbol '__isinf'

however, on the same box, using the same config options but using gcc 3.4.3 the 
build is successful with no issues

have been using:
    binutils 2.16.1
    linux 2.6.11

is this a bug with gcc-4.x or glibc?

thanks
-r
Comment 1 Andrew Pinski 2005-08-05 15:27:12 UTC
glibc  see PR 20652 which references the glibc patch which fixes it there.

*** This bug has been marked as a duplicate of 20652 ***