Bug 23069 - libmudflap.cth timeouts too short
Summary: libmudflap.cth timeouts too short
Status: RESOLVED DUPLICATE of bug 20003
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.0.1
: P2 minor
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-26 06:17 UTC by gschafer
Modified: 2005-10-11 07:30 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-07-28 09:31:21


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gschafer 2005-07-26 06:17:20 UTC
In these files:

libmudflap/testsuite/libmudflap.cth/pass3{7,9}-frag.c

the timeout is overridden to 3 seconds. This is way too short if for example
running the testsuite with -j3 on an SMP box. It results in many timeouts as per
these examples:

http://gcc.gnu.org/ml/gcc-testresults/2005-07/msg01114.html
http://gcc.gnu.org/ml/gcc-testresults/2005-07/msg00451.html

I'm not sure what the ideal timeout should be but 20 seconds made the timeouts
go away for me. Thanks.
Comment 1 Serge Belyshev 2005-07-28 09:31:21 UTC
Confirmed, I saw this one too.
Comment 2 Serge Belyshev 2005-10-11 07:30:27 UTC

*** This bug has been marked as a duplicate of 20003 ***