Bug 22830 - NullPointerException in ToolTipManger
Summary: NullPointerException in ToolTipManger
Status: RESOLVED DUPLICATE of bug 19845
Alias: None
Product: classpath
Classification: Unclassified
Component: swing (show other bugs)
Version: unspecified
: P3 normal
Target Milestone: ---
Assignee: Anthony Balkissoon
URL:
Keywords:
: 22839 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-09 02:59 UTC by from-classpath
Modified: 2005-09-08 18:51 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-08-21 01:13:18


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description from-classpath 2005-01-09 02:59:34 UTC
1. click at menu
2. click in middle of window

------------------------------

$ kaffe-cvs Test
Exception during event dispatch:
java.lang.NullPointerException
   at javax.swing.ToolTipManager.mousePressed (ToolTipManager.java:427)
   at java.awt.AWTEventMulticaster.mousePressed (AWTEventMulticaster.java:333)
   at java.awt.Component.processMouseEvent (Component.java:3047)
   at java.awt.Component.processEvent (Component.java:2911)
   at java.awt.Container.processEvent (Container.java:841)
   at java.awt.Component.dispatchEventImpl (Component.java:4759)
   at java.awt.Container.dispatchEventImpl (Container.java:1536)
   at java.awt.Component.dispatchEvent (Component.java:2276)
   at java.awt.LightweightDispatcher.handleEvent (Container.java:1978)
   at java.awt.Container.dispatchEventImpl (Container.java:1525)
   at java.awt.Window.dispatchEventImpl (Window.java:616)
   at java.awt.Component.dispatchEvent (Component.java:2276)
   at java.awt.EventQueue.dispatchEvent (EventQueue.java:425)
   at java.awt.EventDispatchThread.run (EventDispatchThread.java:81)
   at java.lang.VMThread.run (VMThread.java:123)

------------------------------

import javax.swing.*;
public class Test extends JFrame {
    public Test() {
        JMenu m = new JMenu("File");
        m.setToolTipText("file menu");
        JMenuBar mb = new JMenuBar();
        mb.add(m);
        setJMenuBar(mb);
        setSize(300, 200);
    }
    public static void main(String [] args) {
        JFrame f = new Test();
        f.show();
    }
}
Comment 1 from-classpath 2005-01-11 17:15:25 UTC
This problem is not reproducable anymore after I merged Graydon's thread patch. I close this bug. If you find another testcase which triggers it again please file a new bug.
Comment 2 from-classpath 2005-01-13 16:01:33 UTC
I reopen this bug as it is still there and its just more curious where you exactlcy click.
Comment 3 Thomas Fitzsimmons 2005-08-21 01:13:18 UTC
Strange tooltip behaviour here.  Reassigning to Anthony.
Comment 4 Thomas Fitzsimmons 2005-08-21 01:15:58 UTC
*** Bug 22839 has been marked as a duplicate of this bug. ***
Comment 5 Anthony Balkissoon 2005-09-08 18:51:23 UTC
This bug is similar to 19845, which Lillian is working on.

*** This bug has been marked as a duplicate of 19845 ***