GCC Bugzilla has been upgraded from version 4.4.9 to 5.0rc3. If you see any problem, please report it to bug 64968.
Bug 22587 - shared libraries built with -fvisibility=hidden segfaults
Summary: shared libraries built with -fvisibility=hidden segfaults
Status: RESOLVED DUPLICATE of bug 19664
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 4.0.2
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-21 12:40 UTC by Debian GCC Maintainers
Modified: 2005-07-23 22:49 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
testcase (506 bytes, application/x-tar)
2005-07-21 12:40 UTC, Debian GCC Maintainers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Debian GCC Maintainers 2005-07-21 12:40:11 UTC
[forwarded from http://bugs.debian.org/307207]

seen with g++ 4.0 current CVS gcc-4.0 branch
 
shared libs which are built with -fvisibility=hidden likes to segfault
as the linker don't find the correct symbols for the
__gnu_cxx::mt_allocator internal.

Attached are two source files which produces such a segfaulting shared
lib. The same code without the visibility switch works fine.
Comment 1 Debian GCC Maintainers 2005-07-21 12:40:47 UTC
Created attachment 9316 [details]
testcase
Comment 2 Andrew Pinski 2005-07-21 16:17:56 UTC

*** This bug has been marked as a duplicate of 19664 ***