User account creation filtered due to spam.

Bug 22366 - [meta-bug] issues related to the removal of loop.c
Summary: [meta-bug] issues related to the removal of loop.c
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: middle-end (show other bugs)
Version: 4.1.0
: P2 normal
Target Milestone: 4.2.0
Assignee: Not yet assigned to anyone
URL:
Keywords: meta-bug
Depends on: 20969 7561 11707 13300 19078 19581 20376 21323 21848 22325 24408 24762
Blocks: 21513 24899
  Show dependency treegraph
 
Reported: 2005-07-08 14:49 UTC by Steven Bosscher
Modified: 2006-04-17 18:12 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-02-20 18:29:25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Bosscher 2005-07-08 14:49:47 UTC
This is a meta-bug for any issues related to the removal of the 
old loop  optimizer.  Please make this bug depend on: 
 
1) any bugs in loop.c; 
2) any bugs or pessimizations with -floop-optimize2 (i.e. the 
   new RTL loop optimizers); 
3) any bugs about missed optimizations with -fno-loop-optimize. 
4) other related issues by your own judgement ;-)
Comment 1 Steven Bosscher 2005-07-08 14:58:22 UTC
Bug 7561 is apparently a long-forgotten bug in loop.c array prefetching. 
 
Bug 21323 is a stength reduction ICE in loop.c. 
 
Bug 21848 is a report about loop.c producing wrong code. 
 
Bug 22325 is a missed optimization related to "final value replacement" where 
the final value is not a constant. 
 
Bug 20376 is a report about missing GIV splitting in the new unroller. 
 
 
Also note the wiki page, "http://gcc.gnu.org/wiki/old loop optimizer". 
Comment 2 Andrew Pinski 2005-07-08 15:15:41 UTC
[[old loop optimizer]]
Comment 3 Steven Bosscher 2005-07-08 15:30:53 UTC
Bug 19581 is about store motion that only loop.c currently does. 
 
Bug 19078 reports on a few tuning issues with BIV splitting in the unroller. 
 
Bug 11707 is about the lack of a constant propagation pass after loop2. 
Basically the question is here how late or early loop unrolling should happen. 
Comment 4 Falk Hueffner 2005-08-20 16:56:33 UTC
Bug 13300 is about a bad assumption with respect to overflow and sign extensions
in loop.c.
Comment 5 Zdenek Dvorak 2005-08-20 19:18:53 UTC
This is not an issue blocking removal of loop.c (if anything, it is in favor of 
removal of loop.c).
Comment 6 Zdenek Dvorak 2005-08-20 19:21:41 UTC
Sorry, haven't read the instructions (only the title of the metabug :-)
Comment 7 Andrew Pinski 2005-10-13 01:49:41 UTC
21513 is an issue which can be resolved when loop.c is removed as we don't need to store the profile info due to __builtin_expect in notes.
Comment 8 Steven Bosscher 2006-02-27 14:01:12 UTC
The old RTL loop optimizer is no more on the trunk, so there is no reason to keep this meta-bug open.