Bug 22359 - fseek intrinsic not implemented
Summary: fseek intrinsic not implemented
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.0.1
: P3 enhancement
Target Milestone: 4.3.0
Assignee: Not yet assigned to anyone
URL: http://gcc.gnu.org/ml/gcc-patches/200...
Keywords:
Depends on:
Blocks: 19292
  Show dependency treegraph
 
Reported: 2005-07-08 01:29 UTC by Joseph Wang
Modified: 2007-06-16 22:51 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work: 4.3.0
Known to fail: 4.1.2 4.2.0
Last reconfirmed: 2007-05-01 10:55:49


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Wang 2005-07-08 01:29:11 UTC
This subroutine

      subroutine  locend (nt)
      call fseek(nt, 0, 2)
      print *,' end encountered on read ',nt
      return
      end

with this link

gfortran colapse.o  -L../lib -lboom -lgfortran -lc -o boom

gives

../lib/libboom.a(locend.o): In function `locend_':
/home/joe/boom/hcol/locend.F:3: undefined reference to `fseek_'
Comment 1 Andrew Pinski 2005-07-08 14:58:38 UTC
Confirmed.
Comment 2 Daniel Franke 2007-05-04 19:34:00 UTC
Fixed in trunk. 
Due to a typo in the PR number, the commit message went to PR22539. 
Sorry for that :(

As it is a regression wrt g77, this patch probably needs to be backported to 4.1/4.2. Unassigning myself for now.
Comment 3 Thomas Koenig 2007-05-27 08:49:27 UTC
Frankly, I don't think we need to bother with a 4.2
backport.

If nobody objects, I'll close this shortly.
Comment 4 Daniel Franke 2007-06-16 22:51:02 UTC
No backport to 4.2. Closing.