User account creation filtered due to spam.

Bug 22289 - problem in gimp downscaling routines when compiling with -mfpmath=sse
Summary: problem in gimp downscaling routines when compiling with -mfpmath=sse
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.4.4
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ssemmx, wrong-code
Depends on:
Blocks:
 
Reported: 2005-07-04 06:19 UTC by mkrisch
Modified: 2005-09-05 21:14 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mkrisch 2005-07-04 06:19:20 UTC
i have entered a bug for gimp (#309170) in which gimp would crash when i opened
an image of the same resolution as my current screen.  in that situation, gimp
automatically downscales the image to fit on the screen.

when gimp was compiled with -mfpmath=sse the crash would occur. on recompiling
without that option, gimp operates correctly.

the complete thread for the bug can be found at
http://bugzilla.gnome.org/show_bug.cgi?id=309170, however you can find the
details for my system and the compilation options below:

[ebuild   R   ] media-gfx/gimp-2.2.7-r1  -aalib (-altivec) -debug +doc
+gimpprint +gtkhtml -hardened +jpeg +lcms -mmx +mng +png +python -scanner -smp
-sse +svg +tiff +wmf 0 kB

linux kernel 2.6.12

emerge --info

Portage 2.0.51.19 (default-linux/x86, gcc-3.4.4, glibc-2.3.5-r0, 2.6.12-love1 i686)
=================================================================
System uname: 2.6.12-love1 i686 Intel(R) Pentium(R) M processor 1500MHz
Gentoo Base System version 1.6.12
Python:              dev-lang/python-2.3.5,dev-lang/python-2.4.1-r1 [2.4.1 (#1,
Jun 20 2005, 17:52:12)]
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.8.5-r3, 1.6.3, 1.9.5, 1.7.9-r1, 1.4_p6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-Os -march=pentium-m -mmmx -msse -msse2 -fforce-addr -ftracer
-mfpmath=sse -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=pentium-m -mmmx -msse -msse2 -fforce-addr -ftracer
-mfpmath=sse -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://mirror.pacific.net.au/linux/Gentoo
http://mirror.isp.net.au/pub/gentoo/ ftp://mirror.isp.net.au/pub/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac acpi alsa avi bash-completion berkdb bitmap-fonts bonobo
bzip2 cairo cdr crypt cups curl dbus divx4linux dvd eds emboss encode esd exif
fam fbcon foomaticdb gd gdbm gif gnome gpm gstreamer gtk gtk2 guile hal howl
imagemagick imlib java jpeg ldap libg++ libwww mad mikmod mmx mono motif mozilla
mp3 mpeg mysql ncurses nptl offensive ogg oggvorbis opengl oss pam pcmcia pda
pdflib perl pic png python qt quicktime readline samba sdl spell sqlite sse sse2
ssl svg tcpd tetex theora tiff truetype truetype-fonts type1-fonts usb v4l
vorbis xinerama xml2 xv xvid zlib video_cards_radeon userland_GNU kernel_linux
elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Andrew Pinski 2005-07-04 15:28:34 UTC
We need a testcase.
Comment 2 Giovanni Bajo 2005-07-04 15:34:13 UTC
To produce a testcase, you could try extracting the routine that is miscompiled 
and attach it to this bug (in a compilable form, so preprocessed with all 
needed headers). I believe the GIMP folk can help you with this.

It might be that the bug is visible by just looking at the assembly code 
generated by the compiler (-S). 
Comment 3 Andrew Pinski 2005-09-04 19:10:57 UTC
No feedback in 3 months.
Comment 4 mkrisch 2005-09-04 23:00:35 UTC
never got any feedback from the gimp folk to provide a test case.  so i will
just stick to compiling without -mfpmath=sse as a work around.  

invalid doesn't seem to be the right sort of resolution state, since there is a
bug.  maybe suspended would be better, recognizing that there is a bug, but that
it probably won't be fixed.
Comment 5 Steven Bosscher 2005-09-05 21:14:18 UTC
Without a test case, the bug report is invalid even if you're seeing a 
legitimate bug.  That's why it is closed as INVALID.  Bugs are put in 
the SUSPENDED state if the problem is reproducible but not fixable.