User account creation filtered due to spam.

Bug 22133 - In MinGW trailing slash forward not allowed in include path
Summary: In MinGW trailing slash forward not allowed in include path
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 3.4.2
: P2 minor
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 20594 29851 (view as bug list)
Depends on:
Blocks: 29842
  Show dependency treegraph
 
Reported: 2005-06-21 02:03 UTC by Onno Hommes
Modified: 2011-10-02 12:40 UTC (History)
5 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-01-24 04:33:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Onno Hommes 2005-06-21 02:03:13 UTC
For a detailed description of this bug see:

https://sourceforge.net/tracker/?func=detail&atid=102435&aid=1053052&group_id=2435

In short the file c-incpath.c (near line 331) needs to be modified to remove the
trailing slash if HAVE_DOS_BASED_FILE_SYSTEM is true. It seems on newer windows
systems the trailing slash starts to become a problem. My current makefiles all
have trailing slashes for each include path to support compilers that require
the trailing slash. As a result I can't upgrade to the latest MinGW gcc build.

I classified this as minor since it effects portability of code.
Comment 1 Andrew Pinski 2005-06-21 03:16:19 UTC
IIRC this was discussed on the gcc-patches or gcc list just this year.
Comment 2 Andrew Pinski 2005-06-21 04:11:50 UTC
See the thread: <http://gcc.gnu.org/ml/gcc-patches/2005-05/msg01267.html>.

I don't know what happened to it.
Comment 3 Andrew Pinski 2005-07-07 13:34:12 UTC
*** Bug 20594 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Pinski 2007-04-05 19:15:51 UTC
*** Bug 29851 has been marked as a duplicate of this bug. ***
Comment 5 Jorn Wolfgang Rennecke 2007-04-10 10:58:24 UTC
(In reply to comment #2)
> See the thread: <http://gcc.gnu.org/ml/gcc-patches/2005-05/msg01267.html>.
> 
> I don't know what happened to it.

This is the latest version of the patch:

http://gcc.gnu.org/ml/gcc-patches/2006-03/msg00598.html

AFAICT, it has never been reviewed by anyone who could approve it.
I am not currently working on this - I have other things on my mind,
like the lack of response from the copyright clerk.
Comment 6 Eric Weddington 2007-04-10 14:11:48 UTC
Danny,
Can you take a look at this bug and the corresponding patch in comment #5? This issue has been around a long time, and the fix has worked for a long time too. It would be nice if the fix could be committed.

Thanks
Comment 7 Nathan Froyd 2007-05-07 18:41:39 UTC
Subject: Bug 22133

Author: froydnj
Date: Mon May  7 17:41:35 2007
New Revision: 124504

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=124504
Log:
	PR 22133
	* c-incpath.c (add_path): Strip trailing path separators.

Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/c-incpath.c

Comment 8 Kai Tietz 2011-02-25 13:15:01 UTC
(In reply to comment #0)
> For a detailed description of this bug see:
> 
> https://sourceforge.net/tracker/?func=detail&atid=102435&aid=1053052&group_id=2435
> 
> In short the file c-incpath.c (near line 331) needs to be modified to remove the
> trailing slash if HAVE_DOS_BASED_FILE_SYSTEM is true. It seems on newer windows
> systems the trailing slash starts to become a problem. My current makefiles all
> have trailing slashes for each include path to support compilers that require
> the trailing slash. As a result I can't upgrade to the latest MinGW gcc build.
> 
> I classified this as minor since it effects portability of code.

Does the patch from Nathan Froyd fixed the issue for you?  My tests have shown that issue is solved by it, but I would like that you can confirm this.
Comment 9 Paolo Carlini 2011-10-02 10:22:35 UTC
Fixed.