Bug 21996 - [4.0 Regression] gcc.dg/format/ext-2.c
Summary: [4.0 Regression] gcc.dg/format/ext-2.c
Status: RESOLVED DUPLICATE of bug 12096
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.0.1
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-10 10:40 UTC by Haren Visavadia
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Haren Visavadia 2005-06-10 10:40:35 UTC
When running the testsuite with  4.0-20050609
(http://gcc.gnu.org/ml/gcc-testresults/2005-06/msg00629.html)

I get the following testsuite failures:

FAIL: gcc.dg/format/ext-2.c   bad use of I flag (test for warnings, line 72)
FAIL: gcc.dg/format/ext-2.c   (test for excess errors)
FAIL: gcc.dg/format/ext-2.c  -DWIDE  bad use of I flag (test for warnings, line 72)
FAIL: gcc.dg/format/ext-2.c  -DWIDE  (test for excess errors)


The above testsuite failure do not occur when running the testsuite with GCC
4.0.1 RC (http://gcc.gnu.org/ml/gcc-testresults/2005-06/msg00504.html)
Comment 1 joseph@codesourcery.com 2005-06-10 12:16:36 UTC
Subject: Re:  New: [4.0 Regression]  gcc.dg/format/ext-2.c

On Fri, 10 Jun 2005, themis_hv at yahoo dot co dot uk wrote:

> When running the testsuite with  4.0-20050609
> (http://gcc.gnu.org/ml/gcc-testresults/2005-06/msg00629.html)
> 
> I get the following testsuite failures:
> 
> FAIL: gcc.dg/format/ext-2.c   bad use of I flag (test for warnings, line 72)
> FAIL: gcc.dg/format/ext-2.c   (test for excess errors)
> FAIL: gcc.dg/format/ext-2.c  -DWIDE  bad use of I flag (test for warnings, line 72)
> FAIL: gcc.dg/format/ext-2.c  -DWIDE  (test for excess errors)
> 
> 
> The above testsuite failure do not occur when running the testsuite with GCC
> 4.0.1 RC (http://gcc.gnu.org/ml/gcc-testresults/2005-06/msg00504.html)

Does your installation of "expect" have the patch from bug 12096 applied?  
The normal cause of this problem is a broken installation of "expect" 
without that patch.

Comment 2 Haren Visavadia 2005-06-10 15:35:30 UTC

*** This bug has been marked as a duplicate of 12096 ***