User account creation filtered due to spam.

Bug 21701 - No flag to turn off warning: warning: template-argument `<anonymous enum>' uses anonymous type
Summary: No flag to turn off warning: warning: template-argument `<anonymous enum>' ...
Status: RESOLVED DUPLICATE of bug 21514
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.3
: P2 enhancement
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: diagnostic
Depends on: 21514
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-21 17:54 UTC by Mat Marcus
Modified: 2005-09-16 16:01 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mat Marcus 2005-05-21 17:54:02 UTC
We are currently discussing this issue in the Core Working group of the ISO 
C++ committee. Currently there is not agreement that such an instantiation 
should be disallowed. In particular, the case of an overloaded operator that 
operates on enums is under consideration. In any case, there does not seem to 
be a mechanism to suppress this warning at the moment.
Comment 1 Andrew Pinski 2005-05-21 18:01:32 UTC

*** This bug has been marked as a duplicate of 21514 ***
Comment 2 Gabriel Dos Reis 2005-05-21 18:32:04 UTC
Subject: Re:  No flag to turn off warning:   warning: template-argument `<anonymous enum>' uses anonymous type

"pinskia at gcc dot gnu dot org" <gcc-bugzilla@gcc.gnu.org> writes:

| ------- Additional Comments From pinskia at gcc dot gnu dot org  2005-05-21 18:01 -------
| 
| 
| *** This bug has been marked as a duplicate of 21514 ***
| 
| -- 
|            What    |Removed                     |Added
| ----------------------------------------------------------------------------
|              Status|UNCONFIRMED                 |RESOLVED
|          Resolution|                            |DUPLICATE

Andrew --

  This is a separate bug.  It is specifically asking for a flag to
turn off the diagnostic.  This is a request for a practical solution,
while waiting for the committee to seal the details.  I you write or
port C++ programs, you'll realize how impractical the current
implementation/rule is.  The enums could come fromo system headers and
such.   That is entiry different from the one you
think this is a duplciate of.  Please repoen the PR and mark it as
feature request.

-- Gaby
Comment 3 Gabriel Dos Reis 2005-05-21 18:55:17 UTC
People should not hastly close bug PRs without proper analysis.
Comment 4 Andrew Pinski 2005-09-16 16:01:41 UTC
Since PR 21514 is now closed as fixed, I am just going to close this as a dup of bug 21514 since we 
accept the code unconditionally now.

*** This bug has been marked as a duplicate of 21514 ***