Bug 21578 - ICE in reload_cse_simplify_operands for Coldfire.
Summary: ICE in reload_cse_simplify_operands for Coldfire.
Status: RESOLVED WORKSFORME
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.1.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-15 07:31 UTC by Chris Johns
Modified: 2005-11-21 14:56 UTC (History)
5 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: m68k-rtems
Build:
Known to work: 3.2.3 3.4.4
Known to fail: 4.0.0
Last reconfirmed: 2005-05-15 11:06:46


Attachments
Compressed preprocessed file showing the error. (8.71 KB, application/octet-stream)
2005-05-15 07:34 UTC, Chris Johns
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Johns 2005-05-15 07:31:48 UTC
Compiling RTEMS with -O3 the webserver code with 4.0.0 and 4.1.0 generates the
following ICE:

$ m68k-rtems-gcc -m5200 --pipe -DHAVE_CONFIG_H   -I.. -I../../../lib/include
-DWEBS -DUEMF  -Wall -fasm -O3 -g  -m5200 -MT libhttpd_a-ejlex.o -MD -MP -MF
".deps/libhttpd_a-ejlex.Tpo" -c -o libhttpd_a-ejlex.o `test -f 'ejlex.c' || echo
'../../../../../head/cpukit/httpd/'`ejlex.c -save-temps
../../../../../head/cpukit/httpd/ejlex.c: In function ‘ejLexGetToken’:
../../../../../head/cpukit/httpd/ejlex.c:207: error: insn does not satisfy its
constraints:
(insn 3295 1381 1382 98 ../../../../../head/cpukit/httpd/ejlex.c:678 (set
(reg:QI 1 %d1)
        (reg:QI 8 %a0)) 34 {*m68k.md:754} (nil)
    (nil))
../../../../../head/cpukit/httpd/ejlex.c:207: internal compiler error: in
reload_cse_simplify_operands, at postreload.c:391
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

$ m68k-rtems-gcc -v
Using built-in specs.
Target: m68k-rtems
Configured with: ../cvs/head/configure --target=m68k-rtems
--prefix=/local/tools/head --with-gnu-as --with-gnu-ld --with-newlib
--enable-threads=rtems --enable-languages=c,c++
Thread model: rtems
gcc version 4.1.0 20050515 (experimental)
Comment 1 Chris Johns 2005-05-15 07:34:26 UTC
Created attachment 8890 [details]
Compressed preprocessed file showing the error.
Comment 2 Chris Johns 2005-05-15 07:35:31 UTC
Compile the patch with:

m68k-rtems-gcc -m5200 -fasm -O3 -g ejlex.i -c

The ICE only shows with -O3. Using -O2 compiles the file.
Comment 3 Ralf Corsepius 2005-05-15 11:06:46 UTC
I can reproduce the bug
Comment 4 Kazu Hirata 2005-11-19 21:05:39 UTC
Is this still reproducible?
A quick check with m68k-none-elf did not reproduce the ICE.
Comment 5 Ralf Corsepius 2005-11-20 05:38:29 UTC
(In reply to comment #4)
> Is this still reproducible?
> A quick check with m68k-none-elf did not reproduce the ICE.

Confirmed, I can't reproduce it with my latest rtems-toolchain: 
m68k-rtems4.7-gcc (GCC) 4.0.1 (RTEMS gcc-4.0.1-20050727/newlib-1.13.0-20050912
Comment 6 Kazu Hirata 2005-11-21 02:26:51 UTC
Shall we close this as WORKSFORME?
Comment 7 Joel Sherrill 2005-11-21 14:56:44 UTC
(In reply to comment #6)
> Shall we close this as WORKSFORME?

Looks like it.