Bug 21522 - compile-time failure - ICE in output_constant_pool_2, at varasm.c
Summary: compile-time failure - ICE in output_constant_pool_2, at varasm.c
Status: RESOLVED DUPLICATE of bug 21163
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code, ssemmx
Depends on:
Blocks:
 
Reported: 2005-05-11 22:38 UTC by arminu
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: x86_64
Target: x86_64
Build: x86_64
Known to work:
Known to fail:
Last reconfirmed:


Attachments
preprocessed source (17.35 KB, application/octet-stream)
2005-05-11 22:40 UTC, arminu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description arminu 2005-05-11 22:38:32 UTC
compiler version: 
 
$ g++4 -v 
Using built-in specs. 
Target: x86_64-unknown-linux-gnu 
Configured with: ../gcc-4.0.0/configure --prefix=/home/casa/gcc4 
--program-suffix=4 --enable-threads=posix --enable-languages=c,c++,f95 
--with-system-zlib --enable-shared --enable-__cxa_atexit --disable-checking 
Thread model: posix 
gcc version 4.0.0 
 
failed compilation command: 
$ g++4 -Wall -O3 -msse2 -mfpmath=sse -finline -finline-limit=12000 
-fomit-frame-pointer -DNDEBUG -save-temps -c AMatrix-double.cpp -o 
AMatrix-double.o 
AMatrix-double.cpp: In member function 'int 
Matrix<double>::ludcmp(Matrix<double>&, Vector<int>&, int&)': 
AMatrix-double.cpp:197: internal compiler error: in output_constant_pool_2, at 
varasm.c:3135 
Please submit a full bug report, 
with preprocessed source if appropriate.
Comment 1 arminu 2005-05-11 22:40:16 UTC
Created attachment 8867 [details]
preprocessed source

attached the *.ii file from the -save-temps compilation
Comment 2 Andrew Pinski 2005-05-11 22:42:27 UTC

*** This bug has been marked as a duplicate of 21163 ***