Bug 21452 - insn does not satisfy its constraints
Summary: insn does not satisfy its constraints
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.3.4
: P2 normal
Target Milestone: 3.4.0
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code, ssemmx
Depends on:
Blocks:
 
Reported: 2005-05-08 14:56 UTC by Maciej Blizinski
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host:
Target: i486-slackware-linux
Build:
Known to work: 4.1.0 3.4.0
Known to fail:
Last reconfirmed:


Attachments
preprocessed file ic_predict.i (19.85 KB, application/octet-stream)
2005-05-08 14:57 UTC, Maciej Blizinski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Blizinski 2005-05-08 14:56:24 UTC
maciej@leon:~/src/MPlayer-1.0pre7/libfaad2$ gcc --version
gcc (GCC) 3.3.4

System type: GNU/Linux Slackware 10.1 on Celeron M 1500MHz
Hardware: Fujitsu-Siemens Amilo Pro V2000D

Complete gcc command that triggers the error.

maciej@leon:~/src/MPlayer-1.0pre7/libfaad2$ LC_ALL=C make
cc -c -I. -I../libvo -I../../libvo -I/usr/X11/include -fno-PIC -O3
-march=pentium3 -save-temps -pipe -fomit-frame-pointer -mfpmath=sse -D_REENTRANT
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64   -o ic_predict.o ic_predict.c
cc: warning: -pipe ignored because -save-temps specified
ic_predict.c: In function `ic_predict':
ic_predict.c:81: error: insn does not satisfy its constraints:
(insn 622 495 228 6 0x4030823c (set (reg/v:SF 29 emm0 [72])
        (const_double:SF 0 [0x0] 0.0 [0x0.0p+0])) 61 {*movsf_1} (nil)
    (nil))
ic_predict.c:81: internal compiler error: in build_def_use, at regrename.c:782
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make: *** [ic_predict.o] Error 1
Comment 1 Maciej Blizinski 2005-05-08 14:57:35 UTC
Created attachment 8838 [details]
preprocessed file ic_predict.i
Comment 2 Uroš Bizjak 2005-07-21 08:22:45 UTC
The testcase compiles OK with gcc-4.1, "gcc -O3 -march=pentium3 -mfpmath=sse".

BTW: gcc-3.3.4 is a bit old now, I suggest you upgrade to a newer gcc, at least 
to 3.4.x series. This bug won't be fixed in 3.3.x.

I suggest to close it as WONTFIX.
Comment 3 Andrew Pinski 2005-07-21 18:04:37 UTC
Fixed for 3.4.0 and upwards.