Bug 21252 - ICE: (in c_parse_error, at c-common.c:5885)
Summary: ICE: (in c_parse_error, at c-common.c:5885)
Status: RESOLVED DUPLICATE of bug 17401
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.4.4
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-invalid-code
Depends on:
Blocks:
 
Reported: 2005-04-27 14:32 UTC by Lothar
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
This preprocessed file causes an ice. (34.07 KB, application/octet-stream)
2005-04-27 14:35 UTC, Lothar
Details
This preprocessed file causes an ice. (33.10 KB, application/x-bzip2)
2005-04-27 14:46 UTC, Lothar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lothar 2005-04-27 14:32:09 UTC
I got the following ice:

/usr/local/bin/g++ -save-temps -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include
-Wall -O9 -march=athlon -MT atom_co64.lo -MD -MP -MF .deps/atom_co64.Tpo -c
atom_co64.cpp  -fPIC -DPIC
In file included from mp4common.h:36,
                 from atom_co64.cpp:22:
mp4property.h:61: internal compiler error: tree check: expected identifier_node,
have integer_cst in c_parse_error, at c-common.c:5885
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

These are the build specs of the gcc being used:

Reading specs from /usr/local/lib/gcc/i686-pc-linux-gnu/3.4.4/specs
Configured with: /home/ltg/software/src/work/gcc-3.4-20050422/configure
--enable-threads=posix --enable-libgcj --enable-shared --enable-__cxa_atexit
--enable-version-specific-runtime-libs --enable-checking
--enable-gather-detailed-mem-stats --disable-nls
--enable-languages=c,c++,f77,objc,java,ada --enable-libgcj-multifile --with-x
--enable-java-awt=gtk,xlib
Thread model: posix
gcc version 3.4.4 20050422 (prerelease)

The preprocessed file will follow as an attachment.

Lothar
Comment 1 Lothar 2005-04-27 14:35:27 UTC
Created attachment 8755 [details]
This preprocessed file causes an ice.
Comment 2 Andrew Pinski 2005-04-27 14:42:39 UTC
Can you please re-attach the preprocessed source and not encode the file.
Comment 3 Lothar 2005-04-27 14:46:58 UTC
Created attachment 8756 [details]
This preprocessed file causes an ice.
Comment 4 Andrew Pinski 2005-04-27 14:54:22 UTC
On the mainline (and I think 4.0 also), we get:
mp4property.h:61: error: invalid pure specifier (only `= 0' is allowed) before ';' token
mp4property.h:77: error: invalid pure specifier (only `= 0' is allowed) before ';' token
mp4property.h:78: error: invalid pure specifier (only `= 0' is allowed) before ';' token
mp4property.h:82: error: invalid pure specifier (only `= 0' is allowed) before ';' token
mp4property.h:84: error: invalid pure specifier (only `= 0' is allowed) before ';' token
mp4property.h:87: error: invalid pure specifier (only `= 0' is allowed) before ';' token
rtphint.h:38: error: invalid pure specifier (only `= 0' is allowed) before ';' token
rtphint.h:39: error: invalid pure specifier (only `= 0' is allowed) before ';' token

This is a dup of bug 17401 which is fixed for 4.0.0.

*** This bug has been marked as a duplicate of 17401 ***