Bug 21178 - GCC4 series fails to compile glibc 2.3.x
Summary: GCC4 series fails to compile glibc 2.3.x
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: other (show other bugs)
Version: 4.1.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-23 14:25 UTC by Tobias Gerschner
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Gerschner 2005-04-23 14:25:18 UTC
First entry so please stay calm and point me towards to your rules to apply to them.

I tried to use GCC4 to compile a whole LFS toolchain. I compiled several
GCC-4.X.X with GCC 3.4.3 and furthermore started to compile using GCC4. I used
pretty clean environments based on LFS.

No matter what I did here is the last command which seems to cause the failure:

gcc ../sysdeps/ieee754/dbl-64/s_isinf.c -c -std=gnu99 -O3 -Wall -Winline
-Wstrict-prototypes -Wwrite-strings -m32 -maccumulate-outgoing-args -march=i686
-mtune=i686 -pipe -mpreferred-stack-boundary=4 -fomit-frame-pointer -fPIC  
-Wno-uninitialized -D__NO_MATH_INLINES -D__LIBC_INTERNAL_MATH_INLINES
-I../include -I. -I/usr/src/yoper/BUILD/glibc-build/math -I.. -I../libio
-I../nptl -I/usr/src/yoper/BUILD/glibc-build -I../sysdeps/i386/elf
-I../nptl/sysdeps/unix/sysv/linux/i386/i686
-I../nptl/sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux
-I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../nptl/sysdeps/unix/sysv
-I../nptl/sysdeps/unix -I../nptl/sysdeps/i386/i686 -I../nptl/sysdeps/i386
-I../libidn/sysdeps/unix -I../sysdeps/unix/sysv/linux/i386
-I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common
-I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../sysdeps/unix/sysv/i386
-I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../sysdeps/unix
-I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../sysdeps/i386/i686
-I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu
-I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96
-I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754
-I../sysdeps/generic/elf -I../sysdeps/generic -nostdinc -isystem
/usr/bin/../lib/gcc/i686-pc-linux-gnu/4.1.0/include -isystem /usr/include
-D_LIBC_REENTRANT -D_LIBC_REENTRANT -include ../include/libc-symbols.h  -DPIC
-DSHARED     -o /usr/src/yoper/BUILD/glibc-build/math/s_isinf.os -MD -MP -MF
/usr/src/yoper/BUILD/glibc-build/math/s_isinf.os.dt -MT
/usr/src/yoper/BUILD/glibc-build/math/s_isinf.os

The result is the following:

../sysdeps/ieee754/dbl-64/s_isinf.c:29: error: 'isinf' aliased to undefined
symbol '__isinf'
make[2]: *** [/usr/src/yoper/BUILD/glibc-build/math/s_isinf.os] Fehler 1

Using gcc -v -save-temps I got the following:

gcc: warning: -pipe ignored because -save-temps specified
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: ../gcc-4.1-20050417/configure --host=i686-pc-linux-gnu
--build=i686-pc-linux-gnu --target=i686-pc-linux-gnu --enable-shared
--enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
--enable-languages=c,c++
Thread model: posix
gcc version 4.1.0 20050417 (experimental)
 /usr/bin/../libexec/gcc/i686-pc-linux-gnu/4.1.0/cc1 -E -quiet -nostdinc -v
-I../include -I. -I/usr/src/yoper/BUILD/glibc-build/math -I.. -I../libio
-I../nptl -I/usr/src/yoper/BUILD/glibc-build -I../sysdeps/i386/elf
-I../nptl/sysdeps/unix/sysv/linux/i386/i686
-I../nptl/sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux
-I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../nptl/sysdeps/unix/sysv
-I../nptl/sysdeps/unix -I../nptl/sysdeps/i386/i686 -I../nptl/sysdeps/i386
-I../libidn/sysdeps/unix -I../sysdeps/unix/sysv/linux/i386
-I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common
-I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../sysdeps/unix/sysv/i386
-I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../sysdeps/unix
-I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../sysdeps/i386/i686
-I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu
-I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96
-I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754
-I../sysdeps/generic/elf -I../sysdeps/generic -iprefix
/usr/bin/../lib/gcc/i686-pc-linux-gnu/4.1.0/ -MD
/usr/src/yoper/BUILD/glibc-build/math/s_isinf.d -MF
/usr/src/yoper/BUILD/glibc-build/math/s_isinf.os.dt -MP -MT
/usr/src/yoper/BUILD/glibc-build/math/s_isinf.os -MQ
/usr/src/yoper/BUILD/glibc-build/math/s_isinf.os -D__NO_MATH_INLINES
-D__LIBC_INTERNAL_MATH_INLINES -D_LIBC_REENTRANT -D_LIBC_REENTRANT -DPIC
-DSHARED -isystem /usr/bin/../lib/gcc/i686-pc-linux-gnu/4.1.0/include -isystem
/usr/include -include ../include/libc-symbols.h
../sysdeps/ieee754/dbl-64/s_isinf.c -m32 -maccumulate-outgoing-args -march=i686
-mtune=i686 -mpreferred-stack-boundary=4 -std=gnu99 -Wall -Winline
-Wstrict-prototypes -Wwrite-strings -Wno-uninitialized -fomit-frame-pointer
-fPIC -O3 -fpch-preprocess -o s_isinf.i
#include "..." search starts here:
#include <...> search starts here:
 ../include
 .
 /usr/src/yoper/BUILD/glibc-build/math
 ..
 ../libio
 ../nptl
 /usr/src/yoper/BUILD/glibc-build
 ../sysdeps/i386/elf
 ../nptl/sysdeps/unix/sysv/linux/i386/i686
 ../nptl/sysdeps/unix/sysv/linux/i386
 ../nptl/sysdeps/unix/sysv/linux
 ../nptl/sysdeps/pthread
 ../sysdeps/pthread
 ../nptl/sysdeps/unix/sysv
 ../nptl/sysdeps/unix
 ../nptl/sysdeps/i386/i686
 ../nptl/sysdeps/i386
 ../libidn/sysdeps/unix
 ../sysdeps/unix/sysv/linux/i386
 ../sysdeps/unix/sysv/linux
 ../sysdeps/gnu
 ../sysdeps/unix/common
 ../sysdeps/unix/mman
 ../sysdeps/unix/inet
 ../sysdeps/unix/sysv/i386
 ../sysdeps/unix/sysv
 ../sysdeps/unix/i386
 ../sysdeps/unix
 ../sysdeps/posix
 ../sysdeps/i386/i686/fpu
 ../sysdeps/i386/i686
 ../sysdeps/i386/i486
 ../nptl/sysdeps/i386/i486
 ../sysdeps/i386/fpu
 ../sysdeps/i386
 ../sysdeps/wordsize-32
 ../sysdeps/ieee754/ldbl-96
 ../sysdeps/ieee754/dbl-64
 ../sysdeps/ieee754/flt-32
 ../sysdeps/ieee754
 ../sysdeps/generic/elf
 ../sysdeps/generic
 /usr/bin/../lib/gcc/i686-pc-linux-gnu/4.1.0/include
 /usr/include
End of search list.
 /usr/bin/../libexec/gcc/i686-pc-linux-gnu/4.1.0/cc1 -fpreprocessed s_isinf.i
-quiet -dumpbase s_isinf.c -m32 -maccumulate-outgoing-args -march=i686
-mtune=i686 -mpreferred-stack-boundary=4 -auxbase-strip
/usr/src/yoper/BUILD/glibc-build/math/s_isinf.os -O3 -Wall -Winline
-Wstrict-prototypes -Wwrite-strings -Wno-uninitialized -std=gnu99 -version
-fomit-frame-pointer -fPIC -o s_isinf.s
GNU C version 4.1.0 20050417 (experimental) (i686-pc-linux-gnu)
        compiled by GNU C version 4.1.0 20050417 (experimental).
GGC heuristics: --param ggc-min-expand=30 --param ggc-min-heapsize=4096
../sysdeps/ieee754/dbl-64/s_isinf.c:29: error: 'isinf' aliased to undefined
symbol '__isinf'

I hope I sent not to much or less information. This is completely reproducable.
Using gcc-3.4.3 in exactly the same environment does work properly. 

Contact me , when you need further information. I have the .i and the .s file
when somebody needs them.


Thanks Tobias
Comment 1 Andrew Pinski 2005-04-23 14:27:13 UTC
Not a GCC bug, but a glibc bug which has been already been fixed at least in the HEAD of glibc.
Comment 2 Tobias Gerschner 2005-04-23 15:48:33 UTC
Subject: Re:  GCC4 series fails to compile glibc 2.3.x

this was fast, thanks you made my day :)

################

Yoper Team Coordinator

Knowing is not enough; we must apply. Willing is not enough; we must do.




pinskia at gcc dot gnu dot org wrote:

>------- Additional Comments From pinskia at gcc dot gnu dot org  2005-04-23 14:27 -------
>Not a GCC bug, but a glibc bug which has been already been fixed at least in the HEAD of glibc.
>
>  
>