Bug 21005 - [4.1 Regression] gcc.dg/uninit-1.c uninitialized variable warning (test for bogus messages, line 16 fails
[4.1 Regression] gcc.dg/uninit-1.c uninitialized variable warning (test for b...
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: tree-optimization
4.1.0
: P2 normal
: 4.1.0
Assigned To: Not yet assigned to anyone
: diagnostic
Depends on:
Blocks: Wuninitialized
  Show dependency treegraph
 
Reported: 2005-04-13 21:31 UTC by Joseph S. Myers
Modified: 2005-11-02 19:17 UTC (History)
5 users (show)

See Also:
Host:
Target:
Build:
Known to work: 4.0.0
Known to fail: 4.1.0
Last reconfirmed: 2005-04-13 21:34:14


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph S. Myers 2005-04-13 21:31:17 UTC
FAIL: gcc.dg/uninit-1.c uninitialized variable warning (test for bogus messages,
line 16)

has appeared on mainline, apparently for all targets, between 20050408 and
20050409.  This test previously passed.
Comment 1 Andrew Pinski 2005-04-13 21:34:14 UTC
Confirmed.
Comment 2 Andrew Pinski 2005-04-13 22:48:12 UTC
This was caused by the merge of the tcb branch.
Comment 3 Andrew Pinski 2005-06-26 17:07:19 UTC
Fixed.