Bug 20784 - Impossible to mute warning: imaginary constants are a GCC extension
Impossible to mute warning: imaginary constants are a GCC extension
Status: RESOLVED DUPLICATE of bug 7263
Product: gcc
Classification: Unclassified
Component: c
4.1.0
: P2 minor
: ---
Assigned To: Not yet assigned to anyone
: diagnostic
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-06 08:50 UTC by Aaron W. LaFramboise
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron W. LaFramboise 2005-04-06 08:50:21 UTC
float complex c = 1.if;  // warning: imaginary constants are a GCC extension

This warning is generated when -pedantic is specified.  This creates problems 
with perfectly valid standard C99 code such as the following.

double complex d = I;

No particular placement of __extension__ seems to be able to make this warning 
go away.
Comment 1 Joseph S. Myers 2005-04-06 11:15:54 UTC

*** This bug has been marked as a duplicate of 7263 ***