User account creation filtered due to spam.

Bug 20652 - rejects code with an error: aliased to undefined symbol
Summary: rejects code with an error: aliased to undefined symbol
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: rejects-valid
: 23245 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-26 23:58 UTC by Serge Belyshev
Modified: 2005-08-05 15:27 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Serge Belyshev 2005-03-26 23:58:09 UTC
------------------------------------------------------------------------------
extern int foo;
extern int bar __attribute__ ((alias ("foo")));
------------------------------------------------------------------------------

$ gcc foo.i 
foo.i:2: error: ‘bar’ aliased to undefined symbol ‘foo’
$

this code is taken from glibc/sysdeps/wordsize-64/wcstol_l.c and it was accepted
by gcc 3.4 and earlier.
Comment 1 Andreas Jaeger 2005-03-27 08:16:25 UTC
glibc needs to be changed for this, for details chech the thread starting at:
http://sourceware.org/ml/libc-hacker/2005-03/msg00061.html
Comment 2 Andrew Pinski 2005-08-05 15:27:14 UTC
*** Bug 23245 has been marked as a duplicate of this bug. ***