Bug 20605 - [4.1 Regression] gcc.dg/tree-ssa/loop-4.c scan-tree-dump-times iter 0 fails
Summary: [4.1 Regression] gcc.dg/tree-ssa/loop-4.c scan-tree-dump-times iter 0 fails
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 4.1.0
: P2 normal
Target Milestone: 4.1.0
Assignee: Not yet assigned to anyone
URL:
Keywords: missed-optimization
Depends on:
Blocks:
 
Reported: 2005-03-23 16:35 UTC by Joseph S. Myers
Modified: 2005-09-01 21:15 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph S. Myers 2005-03-23 16:35:29 UTC
gcc.dg/tree-ssa/loop-4.c scan-tree-dump-times iter 0 has started failing on
mainline between 20050321 and 20030323, on hppa64-hpux and ia64-hpux (-mlp64
only) but not on hppa2.0w-hpux or ia64-hpux -lilp32.  Results on gcc-testresults
also show it failing on ia64-linux.
Comment 1 Joseph S. Myers 2005-03-23 16:36:27 UTC
That should of course be 20050323 (not 20030323).
Comment 2 Joseph S. Myers 2005-03-24 17:20:07 UTC
This regression affects ia64-linux which is a secondary platform.
Comment 3 Joseph S. Myers 2005-04-17 22:25:13 UTC
Binary search on ia64-hpux shows the failure appeared between 2005-03-22 22:04
UTC and 2005-03-22 22:30 UTC.  The only plausibly responsible patch in that range is

2005-03-22  Zdenek Dvorak  <dvorakz@suse.cz>

        * tree-ssa-loop-ivopts.c (determine_iv_cost): Do not try to preserve
        artificial original candidates.
Comment 4 Andrew Pinski 2005-04-17 23:07:50 UTC
Hmm, maybe we are just selecting the orignal IV as the IV which we should use, this is just a missed 
optimization.
Comment 5 Andrew Pinski 2005-05-16 19:53:36 UTC
Or it might be the testcase which is matching it wrong, someone already asked about this testcase 
before on IRC (IIRC) and the regex was just matching wrongly.
Comment 6 joseph@codesourcery.com 2005-05-16 20:05:50 UTC
Subject: Re:  [4.1 Regression] gcc.dg/tree-ssa/loop-4.c
 scan-tree-dump-times iter 0 fails

On Mon, 16 May 2005, pinskia at gcc dot gnu dot org wrote:

> Or it might be the testcase which is matching it wrong, someone already asked about this testcase 
> before on IRC (IIRC) and the regex was just matching wrongly.

No, that's bug 21341 (if indeed the problem was the regex, the submitter 
of the patch which changed the regex didn't mention the bug and its prior 
change from PASS to FAIL).  There are multiple test assertions within the 
same test file, and when any one changes from PASS to FAIL that is in 
principle, and in practice in this case, a separate bug.

http://gcc.gnu.org/ml/gcc-patches/2005-05/msg01057.html

Comment 7 Joseph S. Myers 2005-09-01 20:27:03 UTC
Appears fixed on ia64-hpux and hppa64-hpux 20050901.
Comment 8 Andrew Pinski 2005-09-01 21:15:35 UTC
Fixed.