Bug 20603 - SPEC ICE's on powerpc-darwin compiling with "-fprofile-arcs -O2 -mpowerpc64"
Summary: SPEC ICE's on powerpc-darwin compiling with "-fprofile-arcs -O2 -mpowerpc64"
Status: RESOLVED DUPLICATE of bug 20249
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.1.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-23 14:21 UTC by Dorit Naishlos
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: powerpc-apple-darwin7.7.0
Target: powerpc-apple-darwin7.7.0
Build: powerpc-apple-darwin7.7.0
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dorit Naishlos 2005-03-23 14:21:36 UTC
I've been seeing the following SPEC ICEs on powerpc-darwin when compiling 
with "-fprofile-arcs -O2 -mpowerpc64":

==> SPEC's gap:
gcc -c -o system.o -DSYS_IS_BSD -DSYS_HAS_IOCTL_PROTO -DSYS_HAS_TIME_PROTO -
DSYS_HAS_SIGNAL_PROTO -DSYS_HAS_ANSI -DSYS_HAS_CALLOC_PROTO -
DSYS_HAS_STDIO_PROTO -fprofile-arcs -O2 -mpowerpc64  system.c

system.c: In function 'SyFopen':
system.c:688: internal compiler error: in schedule_insns, at sched-rgn.c:2549


==> SPEC's gcc:
gcc -c -o c-decl.o  -DHOST_WORDS_BIG_ENDIAN -fno-inline-functions -fprofile-
arcs -O3 -mpowerpc64  c-decl.c

c-decl.c: In function 'duplicate_decls':
c-decl.c:1860: warning: incompatible implicit declaration of built-in 
function 'memcpy'
c-decl.c: In function 'layout_array_type':
c-decl.c:5761: error: unrecognizable insn:
(insn 61 0 0 (set (reg:SI 3 r3 [ t ])
        (reg:DI 3 r3)) -1 (nil)
    (nil))
c-decl.c:5761: internal compiler error: in extract_insn, at recog.c:2042


==> SPEC's crafty:
gcc -c -o swap.o  -DLINUX_SPARC -DSPEC_CPU2000 -fprofile-arcs -O3 -mpowerpc64 
swap.c

swap.c: In function 'Swap':
swap.c:151: error: unrecognizable insn:
(insn 1033 0 0 (set (reg:SI 5 r5 [ source ])
        (reg:DI 2 r2)) -1 (nil)
    (nil))
swap.c:151: internal compiler error: in extract_insn, at recog.c:2042


The extract_insn error also shows up in other SPEC benchmarks.

I think this problem was introduced between Feb. 3rd to Feb. 15th.

This might be a duplicate of PR20203?
Comment 1 Andrew Pinski 2005-03-23 14:24:58 UTC
>This might be a duplicate of PR20203?
no but it is a dup of PR 20249 which has a patch (which was approved but not applied yet).

*** This bug has been marked as a duplicate of 20249 ***