Bug 20495 - [4.0/4.1/4.2/4.3 Regression] building gcj hangs on gcj-dbtool
Summary: [4.0/4.1/4.2/4.3 Regression] building gcj hangs on gcj-dbtool
Status: RESOLVED WONTFIX
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 4.0.0
: P5 normal
Target Milestone: 4.1.3
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-16 14:33 UTC by Mariusz Mazur
Modified: 2007-12-02 21:22 UTC (History)
4 users (show)

See Also:
Host: alpha-pld-linux
Target: alpha-pld-linux
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mariusz Mazur 2005-03-16 14:33:02 UTC
Gcj is built with --enable-gtk-cairo --enable-libgcj-multifile --enable-libgcj-database. While 
building: 
 
creating gcj-dbtool 
./gcj-dbtool -n classmap.db || touch classmap.db 
 
And it hangs. Strace tells me: 
 
$ strace -p 23159 
Process 23159 attached - interrupt to quit 
futex(0x20001921b00, FUTEX_WAIT, 1, NULL <unfinished ...> 
 
And here's gdb: 
 
#0  0x0000020001736404 in pthread_once () from /lib/tls/libpthread.so.0 
#1  0x00000200018a0ab0 in backtrace () from /lib/tls/libc.so.6.1 
#2  0x0000020000b303fc in gnu::gcj::runtime::StackTrace::fillInStackTrace () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#3  0x0000020000c092e4 in gnu::gcj::runtime::StackTrace::StackTrace () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#4  0x0000020000b3c80c in java::lang::Class::forName () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#5  0x0000020000f4461c in gnu::gcj::convert::UnicodeToBytes::getDefaultEncoder 
    () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#6  0x0000020000b9eb4c in java::io::PrintStream::PrintStream () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#7  0x0000020000b744b8 in java::lang::System::__U3c_clinit__U3e_ () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#8  0x0000020000b3c2f4 in java::lang::Class::initializeClass () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#9  0x0000020000b3d098 in _Jv_InitClass () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#10 0x0000020000b73ab4 in java::lang::System::getProperty () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#11 0x0000020000b79270 in java::lang::VMClassLoader::getSystemClassLoader () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#12 0x0000020000b60864 in java::lang::ClassLoader::__U3c_clinit__U3e_ () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#13 0x0000020000b3c2f4 in java::lang::Class::initializeClass () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#14 0x0000020000afc68c in _Jv_CreateJavaVM () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#15 0x0000020000afd1e8 in _Jv_RunMain () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#16 0x0000020000afd488 in JvRunMain () 
   from /home/users/builder/rpm/BUILD/gcc-4.0-20050312/obj-alpha-pld-linux/alpha-pld-linux/libjava/.libs/libgcj.so.6 
#17 0x0000000120002a48 in main ()
Comment 1 Tom Tromey 2005-03-17 02:17:03 UTC
Are there other threads running?
If so, could you send stack traces from these as well?

If not, then something more serious has gone wrong on your system, as it is
hanging on a mutex in the C library.
Comment 2 Andrew Haley 2005-11-01 20:41:12 UTC
THis looks like a hang in the unwinder the very first time any exception is thrown
Comment 3 Mark Mitchell 2006-05-25 02:35:48 UTC
Will not be fixed in 4.1.1; adjust target milestone to 4.1.2.
Comment 4 Tom Tromey 2007-01-30 20:28:07 UTC
Does this still happen?
Comment 5 Wang Guoqin 2007-02-23 14:04:46 UTC
(In reply to comment #4)
> Does this still happen?
> 

Still happening on me, both in 4.1.1-r3 and 4.1.2
Comment 6 Andrew Haley 2007-02-27 09:34:09 UTC
I think we're going to have to change this to a WONTFIX for the 4.1 branch.

If we can get a 4.3 backtrace that will be interesting.
Comment 7 Andrew Pinski 2007-12-02 21:22:17 UTC
No feed back in over 3 months so closing as won'tfix.