Bug 20452 - HEAD fails to build on avr
Summary: HEAD fails to build on avr
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 4.1.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: build
Depends on:
Blocks:
 
Reported: 2005-03-13 13:00 UTC by andy hutchinson
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host: i686-pc-cygwin
Target: avr
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andy hutchinson 2005-03-13 13:00:20 UTC
gcc build fails with:

gcc -c   -g -O2 -DIN_GCC -DCROSS_COMPILE  -W -Wall -Wwrite-strings -Wstrict-prot
otypes -Wmissing-prototypes  -fno-common   -DHAVE_CONFIG_H    -I. -I. -I../../gc
c/gcc -I../../gcc/gcc/. -I../../gcc/gcc/../include -I../../gcc/gcc/../libcpp/inc
lude  ../../gcc/gcc/c-lex.c -o c-lex.o
../../gcc/gcc/c-lex.c: In function `c_lex_with_flags':
../../gcc/gcc/c-lex.c:428: error: too many arguments to function `cpp_spell_toke
n'
make[1]: *** [c-lex.o] Error 1
make[1]: Leaving directory `/home/cvsroot/awhconf/gcc'

make: *** [all-gcc] Error 2
	
Apparently due to:

	*cpp_spell_token (parse_in, tok, name, true) = 0;

in c-lex.c where cpp_spell_token appears to now only have 3 arguments elsewhere.

configured using:
$ ../gcc/configure --prefix=/avrdev --enable-languages="c,c++" --target=avr --d
isable-nls
Comment 1 Andrew Pinski 2005-03-13 14:53:02 UTC
Your libcpp sources don't match the gcc sources, try using a clean build directory and an updated 
libcpp.