User account creation filtered due to spam.

Bug 20049 - __builtin_ia32_loadsss is still documented
Summary: __builtin_ia32_loadsss is still documented
Status: RESOLVED DUPLICATE of bug 25519
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.3.2
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: documentation, patch, ssemmx
: 37250 45718 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-02-18 04:32 UTC by Kirk Korver
Modified: 2011-06-13 21:02 UTC (History)
12 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-02-26 19:14:50


Attachments
patch for trunk to remove references to the removed __builtin_ia32_{pextrw,pinsrw} (232 bytes, patch)
2009-01-14 11:01 UTC, Bernhard Reutner-Fischer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kirk Korver 2005-02-18 04:32:36 UTC
If you look at http://www.dis.com/gnu/gcc/X86-Built-in-Functions.html, you will
find the following statement:

......
The following built-in functions are available when -msse is used.

v4sf __builtin_ia32_loadaps (float *)
    Generates the movaps machine instruction as a load from memory.
void __builtin_ia32_storeaps (float *, v4sf)
    Generates the movaps machine instruction as a store to memory.
v4sf __builtin_ia32_loadups (float *)
    Generates the movups machine instruction as a load from memory.
void __builtin_ia32_storeups (float *, v4sf)
    Generates the movups machine instruction as a store to memory.
v4sf __builtin_ia32_loadsss (float *)
    Generates the movss machine instruction as a load from memory. 
.......

This last line is incorrect. The correct function would be

v4sf __builtin_ia32_loadss (float *)

Notice that there are only 2 's' at the end, while the incorrect documentation
has 3 's'

Thank you for your time.
Sincerely,
Kirk Korver
Comment 1 Andrew Pinski 2005-02-18 04:50:45 UTC
Well this builtin function now has been removed.
Comment 2 Kelley Cook 2005-04-20 18:03:12 UTC
The obvious typo in the docs would still apply to 3.x though.

4.x has the seperate issue that the following functions are no longer available
(I assume intentionally, though it really wasn't announced) yet still documented:

__builtin_ia32_loadaps
__builtin_ia32_loadddup
__builtin_ia32_loadsss [__builtin_ia32_loadss]
__builtin_ia32_movddup
__builtin_ia32_pextrw
__builtin_ia32_pfrsqrtit1
__builtin_ia32_pinsrw
__builtin_ia32_storeaps
__builtin_ia32_storess
Comment 3 Bernhard Reutner-Fischer 2009-01-14 11:01:39 UTC
Created attachment 17098 [details]
patch for trunk to remove references to the removed __builtin_ia32_{pextrw,pinsrw}
Comment 4 Bernhard Reutner-Fischer 2009-01-14 11:02:28 UTC
*** Bug 37250 has been marked as a duplicate of this bug. ***
Comment 5 Bernhard Reutner-Fischer 2009-01-14 11:33:13 UTC
Also applies to the 4_3-branch.
Comment 6 Uroš Bizjak 2010-05-14 07:36:04 UTC
Missing/wrong documentation is covered by PR25519.

*** This bug has been marked as a duplicate of 25519 ***
Comment 7 Ian Lance Taylor 2011-06-13 21:02:30 UTC
*** Bug 45718 has been marked as a duplicate of this bug. ***