User account creation filtered due to spam.

Bug 19845 - Swing ToolTipManager and getLocationOnScreen
Summary: Swing ToolTipManager and getLocationOnScreen
Status: RESOLVED DUPLICATE of bug 23792
Alias: None
Product: classpath
Classification: Unclassified
Component: swing (show other bugs)
Version: unspecified
: P2 normal
Target Milestone: ---
Assignee: Lillian Angel
URL:
Keywords:
: 22830 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-02-09 10:07 UTC by Norman Hendrich
Modified: 2005-09-09 20:46 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-05-14 21:08:33


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Norman Hendrich 2005-02-09 10:07:59 UTC
javax.swing.ToolTipManager causes (eternal) NullPointerExceptions
when JToolTips are enabled on non-showing JComponents, e.g. on
not-yet-shown dialog windows or just-closed dialog windows.

If the bug happens, Swing is unusable, because the main GUI thread
never recovers from the NPEs. ToolTipManager should probably ignore
non-showing components and should be more robust...
I have no small testcase, but a typical stack trace looks like this:

Exception during event dispatch:
java.awt.IllegalComponentStateException: component not showing
   at java.awt.Component.getLocationOnScreen() (/opt/gcc40/lib/libgcj.so.6.0.0)
   at javax.swing.SwingUtilities.convertPointFromScreen(java.awt.Point,
java.awt.Component) (/opt/gcc40/lib/libgcj.so.6.0.0)
   at javax.swing.SwingUtilities.convertPoint(java.awt.Component, int, int,
java.awt.Component) (/opt/gcc40/lib/libgcj.so.6.0.0)
   at javax.swing.SwingUtilities.convertPoint(java.awt.Component,
java.awt.Point, java.awt.Component) (/opt/gcc40/lib/libgcj.so.6.0.0)
   at
javax.swing.ToolTipManager.getContentPaneDeepestComponent(java.awt.event.MouseEvent)
(/opt/gcc40/lib/libgcj.so.6.0.0)
   at javax.swing.ToolTipManager.mouseExited(java.awt.event.MouseEvent)
(/opt/gcc40/lib/libgcj.so.6.0.0)
Comment 1 Andrew Pinski 2005-02-12 22:33:46 UTC
Confirmed.
Comment 2 Thomas Fitzsimmons 2005-08-24 19:28:49 UTC
Lillian, can you have a look at this one?  I assume this is fixed already.
Comment 3 Anthony Balkissoon 2005-09-08 18:51:26 UTC
*** Bug 22830 has been marked as a duplicate of this bug. ***
Comment 4 Lillian Angel 2005-09-09 20:46:05 UTC
Similar to #23792. I have confirmed this.
I am working on fixing #23792, this is a duplicate.

*** This bug has been marked as a duplicate of 23792 ***