Bug 19593 - ICE at build_def_use, at regrename.c:763
Summary: ICE at build_def_use, at regrename.c:763
Status: RESOLVED DUPLICATE of bug 18932
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.4.3
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2005-01-23 19:36 UTC by Joel Sherrill
Modified: 2005-10-24 01:39 UTC (History)
4 users (show)

See Also:
Host:
Target: i386-rtems
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
code which trips problem (17.78 KB, text/plain)
2005-01-23 19:37 UTC, Joel Sherrill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Sherrill 2005-01-23 19:36:36 UTC
This is 

It does not happen with my native x86 linux from 20050113 CVS or i386-rtems
from 20050122

i386-rtems4.7-gcc -mtune=pentium -O4 -c bad.c
i386-rtems4.7-gcc -mtune=i486 -O4 -c bad.c
i386-rtems4.7-gcc -mtune=k6 -O4 -c bad.c
i386-rtems4.7-gcc -O4 -c bad.c

bad.c: In function `pckbd_init_hw':
bad.c:3180: error: insn does not satisfy its constraints:
(insn 4549 52 54 2 (parallel [
            (set (reg:CCNO 17 flags)
                (compare:CCNO (and:QI (reg/v:QI 5 di [orig:61 status ] [61])
                        (const_int -64 [0xffffffc0]))
                    (const_int 0 [0x0])))
            (set (reg/v:QI 5 di [orig:61 status ] [61])
                (and:QI (reg/v:QI 5 di [orig:61 status ] [61])
                    (const_int -64 [0xffffffc0])))
        ]) 205 {*andqi_2} (nil)
    (expr_list:REG_UNUSED (reg/v:QI 5 di [orig:61 status ] [61])
        (nil)))
bad.c:3180: internal compiler error: in build_def_use, at regrename.c:763
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
Comment 1 Joel Sherrill 2005-01-23 19:37:14 UTC
Created attachment 8047 [details]
code which trips problem

Test case file used in description.
Comment 2 Andrew Pinski 2005-01-23 23:45:25 UTC
I think this is a dup of bug 18932 and already fixed in 3.4.4.  (It was a latent bug).
Comment 3 Andrew Pinski 2005-01-23 23:48:45 UTC
Can you try 3.4.4?
Comment 4 Joel Sherrill 2005-01-24 12:11:27 UTC
(In reply to comment #3)
> Can you try 3.4.4?

There is no 3.4.4 on gcc.gnu.org.  Do you mean the head of the 3.4 branch?
Comment 5 Andrew Pinski 2005-06-19 14:54:49 UTC
Does this work with 3.4.4?
Comment 6 Andrew Pinski 2005-10-24 01:39:08 UTC
No feedback in 3 months so assuming this is a dup of bug 18932.

*** This bug has been marked as a duplicate of 18932 ***