Bug 19537 - tic4x does not build -- ICE in libgcc
Summary: tic4x does not build -- ICE in libgcc
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: 4.0.0
Assignee: rsandifo@gcc.gnu.org
URL:
Keywords: build, ice-on-valid-code, patch
: 19859 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-19 18:01 UTC by Joel Sherrill
Modified: 2005-04-20 02:14 UTC (History)
2 users (show)

See Also:
Host:
Target: tic4x-rtems, tic4x-*
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-03-21 17:53:21


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Sherrill 2005-01-19 18:01:03 UTC
This does not appear to be the same as
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14436.

binutils 2.15, gcc from CVS as or 2005-01-19.

This should be reproducible in any other tic4x target.

./gcc/configure --target=tic4x-rtems4.7 --enable-threads=rtems
--prefix=/opt/rtems-test --with-gnu-as --with-gnu-ld --with-newlib --verbose
--with-system-zlib --disable-nls --enable-version-specific-runtime-libs
--enable-languages=c


/usr3/ftp_archive/gnu/gcc/ss/b-head/b-tic4x-rtems4.7/gcc/xgcc
-B/usr3/ftp_archive/gnu/gcc/ss/b-head/b-tic4x-rtems4.7/gcc/ -nostdinc
-B/usr3/ftp_archive/gnu/gcc/ss/b-head/b-tic4x-rtems4.7/tic4x-rtems4.7/newlib/
-isystem
/usr3/ftp_archive/gnu/gcc/ss/b-head/b-tic4x-rtems4.7/tic4x-rtems4.7/newlib/targ-include
-isystem /usr3/ftp_archive/gnu/gcc/ss/b-head/gcc/newlib/libc/include
-B/opt/rtems-test/tic4x-rtems4.7/bin/ -B/opt/rtems-test/tic4x-rtems4.7/lib/
-isystem /opt/rtems-test/tic4x-rtems4.7/include -isystem
/opt/rtems-test/tic4x-rtems4.7/sys-include -O2
-I../../gcc/gcc/../newlib/libc/sys/rtems/include -DIN_GCC -DCROSS_COMPILE   -W
-Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes
-Wold-style-definition  -isystem ./include  -Dexit=unused_exit -g
-DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED -Dinhibit_libc -I. -I
-I../../gcc/gcc -I../../gcc/gcc/ -I../../gcc/gcc/../include
-I../../gcc/gcc/../libcpp/include  -DL_subvsi3 -c ../../gcc/gcc/libgcc2.c -o
libgcc/./_subvsi3.o
../../gcc/gcc/libgcc2.c: In function '__do_global_ctors':
../../gcc/gcc/libgcc2.c:1674: internal compiler error: in integer_all_onesp, at
tree.c:995
Please submit a full bug report,
Comment 1 Andrew Pinski 2005-02-09 19:46:11 UTC
*** Bug 19859 has been marked as a duplicate of this bug. ***
Comment 2 rsandifo@gcc.gnu.org 2005-03-21 17:53:16 UTC
Patch posted here: http://gcc.gnu.org/ml/gcc-patches/2005-03/msg01840.html
Comment 3 CVS Commits 2005-04-04 19:45:25 UTC
Subject: Bug 19537

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-4_0-branch
Changes by:	rsandifo@gcc.gnu.org	2005-04-04 19:45:14

Modified files:
	gcc            : ChangeLog Makefile.in tree-ssa-loop-ivopts.c 

Log message:
	PR target/19537
	* Makefile.in (tree-ssa-loop-ivopts.o): Depend on langhooks.h.
	* tree-ssa-loop-ivopts.c: Include langhooks.h.
	(add_standard_iv_candidates_for_size): New function, extracting code
	from add_standard_iv_candidates and parameterizing it by type size.
	(add_standard_iv_candidates): Use add_standard_iv_candidates_for_size.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=2.7592.2.122&r2=2.7592.2.123
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/Makefile.in.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=1.1447&r2=1.1447.2.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/tree-ssa-loop-ivopts.c.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=2.49.2.1&r2=2.49.2.2

Comment 4 rsandifo@gcc.gnu.org 2005-04-04 19:53:55 UTC
Patch applied to mainline and 4.0.  I forgot to add the PR number
to the initial mainline commit (now corrected) which is why it
didn't show up in the PR.