GCC Bugzilla has been upgraded from version 4.4.9 to 5.0rc3. If you see any problem, please report it to bug 64968.
Bug 19534 - ICE in create_tmp_var, at gimplify.c:368 (boost_1_32_0 python/bienstman1)
Summary: ICE in create_tmp_var, at gimplify.c:368 (boost_1_32_0 python/bienstman1)
Status: RESOLVED DUPLICATE of bug 19299
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-19 16:47 UTC by Michael Cieslinski
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: x86_64-unknown-linux-gnu
Target: x86_64-unknown-linux-gnu
Build: x86_64-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
preprocessed source (172.44 KB, text/plain)
2005-01-19 16:48 UTC, Michael Cieslinski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Cieslinski 2005-01-19 16:47:09 UTC
I build gcc from the actual snapshot gcc-4.0-20050116.
When I compile boost_1_32_0 I get an ICE when I execute the self tests:

Michael Cieslinski


g++  -c  -o bienstman1.o bienstman1.ii
/home/cie019/boost/boost_1_32_0/boost/python/detail/destroy.hpp: In static 
member function 'static void 
boost::python::detail::value_destroyer<false>::execute(const volatile T*) [with 
T = V]':
/home/cie019/boost/boost_1_32_0/boost/python/detail/destroy.hpp:90:   
instantiated from 'void boost::python::detail::destroy_referent_impl(void*, T& 
(*)()) [with T = const V]'
/home/cie019/boost/boost_1_32_0/boost/python/detail/destroy.hpp:101:   
instantiated from 'void boost::python::detail::destroy_referent(void*, T (*)()) 
[with T = const V&]'
/home/cie019/boost/boost_1_32_0/boost/python/converter/rvalue_from_python_data.h
pp:135:   instantiated 
from 'boost::python::converter::rvalue_from_python_data<T>::~rvalue_from_python_
data() [with T = const V&]'
/home/cie019/boost/boost_1_32_0/boost/preprocessor/iteration/detail/local.hpp:34
:   instantiated from 'PyObject* 
boost::python::detail::caller_arity<1u>::impl<F, Policies, Sig>::operator()
(PyObject*, PyObject*) [with F = const A* (*)(const V&), Policies = 
boost::python::return_value_policy<boost::python::reference_existing_object, 
boost::python::default_call_policies>, Sig = boost::mpl::vector2<const A*, 
const V&>]'
/home/cie019/boost/boost_1_32_0/boost/python/object/py_function.hpp:38:   
instantiated from 'PyObject* 
boost::python::objects::caller_py_function_impl<Caller>::operator()(PyObject*, 
PyObject*) [with Caller = boost::python::detail::caller<const A* (*)(const V&), 
boost::python::return_value_policy<boost::python::reference_existing_object, 
boost::python::default_call_policies>, boost::mpl::vector2<const A*, const V&> 
>]'
../../../libs/python/test/bienstman1.cpp:38:   instantiated from here
/home/cie019/boost/boost_1_32_0/boost/python/detail/destroy.hpp:33: internal 
compiler error: in create_tmp_var, at gimplify.c:368
Please submit a full bug report, with preprocessed source if appropriate.

gcc -v
Using built-in specs.
Configured with: ../gcc40/configure --with-arch=opteron --enable-
languages=c,c++ --enable-checking
Thread model: posix
gcc version 4.0.0 20050116 (experimental)
Comment 1 Michael Cieslinski 2005-01-19 16:48:16 UTC
Created attachment 7992 [details]
preprocessed source
Comment 2 Andrew Pinski 2005-01-19 18:38:59 UTC
I already reduced this, this is a dup of bug 19299.

*** This bug has been marked as a duplicate of 19299 ***