Bug 19527 - libgij fails to install in a temporary directory
Summary: libgij fails to install in a temporary directory
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libgcj (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: 4.0.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-19 09:50 UTC by Debian GCC Maintainers
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Debian GCC Maintainers 2005-01-19 09:50:44 UTC
installing with DESTDIR set to a temporary installation directory, the
installation fails when relinking libgij. The failure is hidden, if libgcj can
be found elsewhere on the system.

  Matthias

libtool: install: warning: relinking `libgij.la'
(cd /home/packages/gcc/4.0/gcc-4.0-4.0ds4/build/i486-linux/libjava; /bin/sh ./li
btool --mode=relink /home/packages/gcc/4.0/gcc-4.0-4.0ds4/build/gcc/xgcc -shared
-libgcc -B/home/packages/gcc/4.0/gcc-4.0-4.0ds4/build/gcc/ -nostdinc++ -L/home/p
ackages/gcc/4.0/gcc-4.0-4.0ds4/build/i486-linux/libstdc++-v3/src -L/home/package
s/gcc/4.0/gcc-4.0-4.0ds4/build/i486-linux/libstdc++-v3/src/.libs -B/usr/i486-lin
ux/bin/ -B/usr/i486-linux/lib/ -isystem /usr/i486-linux/include -isystem /usr/i4
86-linux/sys-include -fno-rtti -fnon-call-exceptions -fdollars-in-identifiers -W
switch-enum -D_FILE_OFFSET_BITS=64 -ffloat-store -fno-omit-frame-pointer -I/usr/
X11R6/include -Wextra -Wall -D_GNU_SOURCE -DPREFIX="/usr" -DLIBDIR="/usr/lib" -D
BOOT_CLASS_PATH="/usr/share/java/libgcj-4.0.0.jar" -DJAVA_EXT_DIRS="/usr/share/j
ava/ext" -g -O2 -D_GNU_SOURCE -o libgij.la -rpath /usr/lib/../lib gij.lo libgcj.
la)
/home/packages/gcc/4.0/gcc-4.0-4.0ds4/build/gcc/xgcc -shared-libgcc -B/home/pack
ages/gcc/4.0/gcc-4.0-4.0ds4/build/gcc/ -nostdinc++ -L/home/packages/gcc/4.0/gcc-
4.0-4.0ds4/build/i486-linux/libstdc++-v3/src -L/home/packages/gcc/4.0/gcc-4.0-4.
0ds4/build/i486-linux/libstdc++-v3/src/.libs -B/usr/i486-linux/bin/ -B/usr/i486-
linux/lib/ -isystem /usr/i486-linux/include -isystem /usr/i486-linux/sys-include
 -shared -nostdlib /usr/lib/gcc/i486-linux/../../../lib/crti.o /home/packages/gc
c/4.0/gcc-4.0-4.0ds4/build/gcc/crtbeginS.o  .libs/gij.o  -Wl,--rpath -Wl,/usr/li
b/../lib  -L/home/packages/gcc/4.0/gcc-4.0-4.0ds4/build/i486-linux/libstdc++-v3/
src -L/home/packages/gcc/4.0/gcc-4.0-4.0ds4/build/i486-linux/libstdc++-v3/src/.l
ibs -L/usr/lib/../lib -lgcj -L/home/packages/gcc/4.0/gcc-4.0-4.0ds4/build/i486-l
inux/libjava -L/home/packages/gcc/4.0/gcc-4.0-4.0ds4/build/gcc -L/usr/lib/gcc/i4
86-linux/../../../lib -L/usr/lib/gcc/i486-linux/../.. -L/lib/../lib -lgcc_s -lc 
-lgcc_s  /home/packages/gcc/4.0/gcc-4.0-4.0ds4/build/gcc/crtendS.o /usr/lib/gcc/
i486-linux/../../../lib/crtn.o  -Wl,-soname -Wl,libgij.so.0 -o .libs/libgij.so.0
.0.0
/usr/bin/ld: cannot find -lgcj
collect2: ld returned 1 exit status
libtool: install: error: relink `libgij.la' with the above command before instal
ling it
Comment 1 Andrew Pinski 2005-01-19 14:01:24 UTC
To me it looks like a libtool bug but I could be wrong.
Comment 2 Tom Tromey 2005-01-24 20:56:59 UTC
I believe this was fixed by this patch:

http://gcc.gnu.org/ml/gcc-patches/2005-01/msg01702.html

I haven't checked to verify it however.
Comment 3 Debian GCC Maintainers 2005-01-26 06:57:54 UTC
yes, fixed by the mentioned patch.

  Matthias