Bug 19468 - gcc+binutils combined fails bootstrap
Summary: gcc+binutils combined fails bootstrap
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-16 11:58 UTC by Hans-Peter Nilsson
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host: sparc-sun-solaris2.8
Target: sparc-sun-solaris2.8
Build: sparc-sun-solaris2.8
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Peter Nilsson 2005-01-16 11:58:42 UTC
Building from a combined tree of gcc and binutils using gcc-2.95.2,
I get this error with "Fri Jan 14 01:28:39 UTC 2005" (no configure
arguments, build gcc is gcc-2.95.2, ld used by bootstrap-gcc is
/usr/ccs/bin/ld, as used by bootstrap-gcc is /usr/ccs/bin/as):
...
gcc -DHAVE_CONFIG_H -I. -I/tmp/hptmp/combined/binutils -I. -D_GNU_SOURCE -I.
-I/tmp/hptmp/combined/binutils -I../bfd -I/tmp/hptmp\
/combined/binutils/../bfd -I/tmp/hptmp/combined/binutils/../include
-I/tmp/hptmp/combined/binutils/../intl -I../intl -DLOCALEDIR=\
"\"/usr/local/share/locale\"" -Dbin_dummy_emulation=bin_vanilla_emulation   -W
-Wall -Wstrict-prototypes -Wmissing-prototypes -g \
-O2  -c /tmp/hptmp/combined/binutils/filemode.c
/bin/sh ./libtool --mode=link gcc -W -Wall -Wstrict-prototypes
-Wmissing-prototypes -g -O2   -o size  size.o bucomm.o version.o f\
ilemode.o ../bfd/libbfd.la ../libiberty/libiberty.a
mkdir .libs
gcc -W -Wall -Wstrict-prototypes -Wmissing-prototypes -g -O2 -o size size.o
bucomm.o version.o filemode.o  ../bfd/.libs/libbfd.a \
../libiberty/libiberty.a
Undefined                       first referenced
 symbol                             in file
libintl_bindtextdomain              size.o
libintl_gettext                     size.o
libintl_dgettext                    ../bfd/.libs/libbfd.a(archive.o)
libintl_textdomain                  size.o
ld: fatal: Symbol referencing errors. No output written to size
collect2: ld returned 1 exit status
make[3]: *** [size] Error 1
make[3]: Leaving directory `/tmp/hptmp/obj/binutils'

Yes, this is the binutils build breaking, but building binutils
*by itself* succeeds. It seems that the "intl" subdir component
of gcc is at fault.  I recall it has been this way for a long time.
Usually --disable-nls helps, but see also binutils PR 673.
Comment 1 Andrew Pinski 2005-01-16 16:12:04 UTC
This is a dup of bug 11074.  The problem is related to how the build is picking up the wrong headers.

*** This bug has been marked as a duplicate of 11074 ***
Comment 2 Tim Van Holder 2005-01-17 07:17:49 UTC
(In reply to comment #1)
> This is a dup of bug 11074.  The problem is related to how the build is
picking up the wrong headers.
> 
> *** This bug has been marked as a duplicate of 11074 ***

Actually, it's not really a duplicate of bug 11074 at all, although they have
the same symptoms.  In this case, all the right configury is in place, but the
binutils makefiles don't always specify @INTLLIBS@ when linking.
In 11074, adding @INTLLIBS@ is pointless because it also lacks the gettext
macros that would normally provide @INTLLIBS@.

In any case, it is not a gcc bug, but a binutils one - it's their Makefiles that
are broken.
Comment 3 Hans-Peter Nilsson 2005-01-19 23:11:25 UTC
Reopened as it's not a duplicate... (wait for it)
Comment 4 Hans-Peter Nilsson 2005-01-19 23:12:25 UTC
...and closed as invalid, as this is a binutils bug.  See comment #2.