Bug 19426 - template class and method with different parameter names
Summary: template class and method with different parameter names
Status: RESOLVED DUPLICATE of bug 18962
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.4.1
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-13 14:28 UTC by douze
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: i586-mandrake-linux-gnu
Target: i586-mandrake-linux-gnu
Build: i586-mandrake-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
short c++ code that fails (116 bytes, text/plain)
2005-01-13 14:35 UTC, douze
Details
the code that works (116 bytes, text/plain)
2005-01-13 14:37 UTC, douze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description douze 2005-01-13 14:28:53 UTC
When a class and one of its methods depend on templates, when the method is
defined, the name of the parameters must be the same as in the definition.
Comment 1 Andrew Pinski 2005-01-13 14:33:04 UTC
Do you have an example code?
Comment 2 douze 2005-01-13 14:35:21 UTC
Created attachment 7951 [details]
short c++ code that fails

result with g++ -c 
x.i: In member function `void* Cl<N>::me(T) [with T = T, int N = 1]':
x.i:10: error: `b' undeclared
Comment 3 douze 2005-01-13 14:37:49 UTC
Created attachment 7952 [details]
the code that works

compiles ok
Comment 4 Andrew Pinski 2005-01-13 14:39:23 UTC
This is a dup of bug 18962 which is fixed in 3.4.4 (which is not released yet) and above.

*** This bug has been marked as a duplicate of 18962 ***

*** This bug has been marked as a duplicate of 18962 ***