Bug 19412 - ACATS c761007 - valgrind detects wrong code (Conditional jump or move depends on uninitialised value)
Summary: ACATS c761007 - valgrind detects wrong code (Conditional jump or move depends...
Status: RESOLVED INVALID
Alias: None
Product: gcc
Classification: Unclassified
Component: ada (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: wrong-code
Depends on:
Blocks:
 
Reported: 2005-01-12 22:55 UTC by baldrick@free.fr
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description baldrick@free.fr 2005-01-12 22:55:25 UTC
RUN c761007 
==10563== Memcheck, a memory error detector for x86-linux. 
==10563== Copyright (C) 2002-2004, and GNU GPL'd, by Julian Seward et al. 
==10563== Using valgrind-2.3.0.CVS, a program supervision framework for 
x86-linux. 
==10563== Copyright (C) 2000-2004, and GNU GPL'd, by Julian Seward et al. 
==10563== For more details, rerun with: -v 
==10563== 
==10563== warning: Valgrind's pthread_setschedparam does nothing 
==10563==          (scheduling not changeable) 
==10563==          your program may misbehave as a result 
 
,.,. C761007 ACATS 2.5 05-01-11 16:43:55 
---- C761007 Check that if a finalize procedure invoked by a transfer of 
                control or selection of a terminate alternative attempts 
                to propagate an exception, the exception is ignored, but 
                any other finalizations due to be performed are 
                performed. 
==10563== warning: Valgrind's pthread_attr_destroy does nothing 
==10563==          your program may misbehave as a result 
==10563== warning: Valgrind's pthread_setschedparam does nothing 
==10563==          (scheduling not changeable) 
==10563==          your program may misbehave as a result 
==10563== warning: Valgrind's pthread_cond_destroy is incomplete 
==10563==          (it doesn't check if the cond is waited on) 
==10563==          your program may misbehave as a result 
==10563== warning: Valgrind's pthread_attr_destroy does nothing 
==10563==          your program may misbehave as a result 
==10563== warning: Valgrind's pthread_setschedparam does nothing 
==10563==          (scheduling not changeable) 
==10563==          your program may misbehave as a result 
==10563== warning: Valgrind's pthread_attr_destroy does nothing 
==10563==          your program may misbehave as a result 
==10563== Thread 4: 
==10563== Conditional jump or move depends on uninitialised value(s) 
==10563==    at 0x806BABE: c761007__subtestsB.371 (c761007.adb:12) 
==10563==    by 0x8065625: system__tasking__stages__task_wrapper 
(s-tassta.adb:959) 
==10563==    by 0x1B90D823: thread_wrapper (vg_libpthread.c:795) 
==10563==    by 0xB0016754: do__quit (vg_scheduler.c:1761) 
==10563== warning: Valgrind's pthread_cond_destroy is incomplete 
==10563==          (it doesn't check if the cond is waited on) 
==10563==          your program may misbehave as a result 
==10563== warning: Valgrind's pthread_cond_destroy is incomplete 
==10563==          (it doesn't check if the cond is waited on) 
==10563==          your program may misbehave as a result 
==== C761007 PASSED ============================. 
==10563== 
==10563== ERROR SUMMARY: 2 errors from 1 contexts (suppressed: 17 from 1) 
==10563== malloc/free: in use at exit: 12340 bytes in 7 blocks. 
==10563== malloc/free: 97 allocs, 90 frees, 114602 bytes allocated. 
==10563== For a detailed leak analysis,  rerun with: --leak-check=yes 
==10563== For counts of detected errors, rerun with: -v 
PASS:   c761007
Comment 1 Arnaud Charlet 2005-03-17 10:51:46 UTC
Valgrind is confused by the use of trampolines, so this is not
a GCC bug.

Arno