User account creation filtered due to spam.

Bug 19297 - [4.0 Regression] rejects valid code when compiling Boost.Python test
Summary: [4.0 Regression] rejects valid code when compiling Boost.Python test
Status: RESOLVED DUPLICATE of bug 19299
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.0.0
: P1 critical
Target Milestone: 4.0.0
Assignee: Not yet assigned to anyone
URL:
Keywords: rejects-valid
Depends on: 19299
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 19:37 UTC by Ralf W. Grosse-Kunstleve
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Preprocessed source code (213.24 KB, application/octet-stream)
2005-01-06 19:40 UTC, Ralf W. Grosse-Kunstleve
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf W. Grosse-Kunstleve 2005-01-06 19:37:38 UTC
gcc CVS mainline, 2005/01/06 09:53 PST
Configured with: /net/legless/scratch1/rwgk/gcc_cvs_head/configure --
prefix=/usr/local_cci/gcc_cvs_head_20050106 --enable-languages=c,c++
Red Hat Enterprise Linux WS release 3 (Taroon)
Boost CVS mainline, 2005/01/06 10:09 PST

% g++ -I/net/legless/scratch1/rwgk/hot/boost -I/usr/include/python2.2 -
E /net/legless/scratch1/rwgk/hot/boost/libs/python/test/bienstman1.cpp > 
bienstman1_pp.cpp

% g++ -c bienstman1_pp.cpp

Lots of output ending with:

/net/legless/scratch1/rwgk/hot/boost/boost/python/detail/destroy.hpp:33: 
internal compiler error: in create_tmp_var, at gimplify.c:368
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

The same code compiles with gcc 3.2.3 on the same machine.

I will attach the preprocessed source code. The same file is also available 
here:

http://cci.lbl.gov/~rwgk/bugs/gcc_cvs_head_20050106/bienstman1_pp.cpp.gz
Comment 1 Ralf W. Grosse-Kunstleve 2005-01-06 19:40:12 UTC
Created attachment 7885 [details]
Preprocessed source code
Comment 2 Andrew Pinski 2005-01-06 19:45:19 UTC
Looks like there are two bugs here, one for rejects valid if it is valid as there is an error message before 
the ICE  and one for an ICE on valid code which is definitely a regression.
I will reduce the ICE first and then try to reduce the rejects valid.
Comment 3 Andrew Pinski 2005-01-06 19:55:28 UTC
Ok, the ICE is filed under PR 19299, reducing the rejects valid right now.
Comment 4 Ralf W. Grosse-Kunstleve 2005-01-06 19:57:15 UTC
> ------- Additional Comment #2 From Andrew Pinski 2005-01-06 19:45 [reply] ----
--- 
> Looks like there are two bugs here ...

I've opened another bug report for the second error:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=19298
Comment 5 Andrew Pinski 2005-01-06 20:01:01 UTC
(In reply to comment #4)
> > ------- Additional Comment #2 From Andrew Pinski 2005-01-06 19:45 [reply] ----
> --- 
> > Looks like there are two bugs here ...
> 
> I've opened another bug report for the second error:
Oh, then lets close this as a dup of the new bug which I just opened for the ICE, PR 19299.
Sorry about that I did not know you would be so kind to split them up.  Ok, next up reducing 19298 
then.

*** This bug has been marked as a duplicate of 19299 ***
Comment 6 Volker Reichelt 2005-02-10 22:23:16 UTC
The original testcase still doesn't compile although PR19298 and
PR19299 got fixed. See PR 19883 for the new failure.