Bug 19062 - -Wuninitialized tricked by conditional assignments
Summary: -Wuninitialized tricked by conditional assignments
Status: RESOLVED DUPLICATE of bug 5035
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 4.0.0
: P3 enhancement
Target Milestone: ---
Assignee: Diego Novillo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-17 22:08 UTC by Diego Novillo
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Novillo 2004-12-17 22:08:33 UTC
With the fix for PR 18501 we are now emitting false positives on
gcc.dg/uninit-5.c and gcc.dg/uninit-9.c.

Analysis of problem:

http://gcc.gnu.org/ml/gcc/2004-12/msg00681.html
http://gcc.gnu.org/ml/gcc-patches/2004-12/msg01309.html
Comment 1 Andrew Pinski 2004-12-17 22:41:35 UTC
Isn't this just a dup of the long standing bug 5035?
Comment 2 Diego Novillo 2004-12-17 22:54:16 UTC
Subject: Re:  -Wuninitialized tricked by conditional
 assignments

pinskia at gcc dot gnu dot org wrote:
> ------- Additional Comments From pinskia at gcc dot gnu dot org  2004-12-17 22:41 -------
> Isn't this just a dup of the long standing bug 5035?
> 
Indeed.  I must've searched for the wrong string.


Thanks.  Diego.
Comment 3 Andrew Pinski 2004-12-17 23:12:56 UTC
So closing as a dup then.

*** This bug has been marked as a duplicate of 5035 ***