Bug 18961 - Large output causes testsuite failure
Large output causes testsuite failure
Status: RESOLVED DUPLICATE of bug 12096
Product: gcc
Classification: Unclassified
Component: other
4.0.0
: P3 minor
: ---
Assigned To: Not yet assigned to anyone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-13 17:14 UTC by Chris Jefferson
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Jefferson 2004-12-13 17:14:34 UTC
The following testsuite program fails when added to the libstdc++ testsuite:

#include <iostream>

int main()
{
  for(int i=0;i<1000000;i++)
    std::cout << "C" << std::endl;
}

Is there some reason for this?
Comment 1 Andrew Pinski 2004-12-13 17:21:34 UTC
Are you sure that this is not a dejagnu bug?
Or are you sure that you just don't get a timeout?

Also anything this long will most likely get a timeout on slow machines so, I really doubt that we want 
this, also one thing, we will be filling up the long and with oldder machines with that much space left 
on their hd, I don't think we want this either.
Comment 2 Chris Jefferson 2004-12-13 17:56:17 UTC
I'm fairly sure it's not a timeout (It takes <5 seconds to run on my computer).
It might be a dejagnu bug. Unfortunatly I find it very hard to find out exactly
what is causing this bug.

While I agree that allowing program's output to run out of control is a bad
idea, the problem with the current cutoff system is that it seems quite
unreliable. Around the mark at which the bug occurs (round about 200,000-300,000
characters on my computer) the test will sometimes run and sometimes fail. This
kind of unpredictable behaviour led me to a merry afternoon of debugging (I was
writing a test which outputed a large quantity of state information for testing
reasons) as it randomly appeared and disappeared. I do think that the behaviour
could be more reliable, and at least better documented.
Comment 3 Joseph S. Myers 2005-02-06 18:46:48 UTC
Does your version of expect include the patch in bug 12096?  If not, and
if using a version with that patch fixes your problem, then this would be
a duplicate of that bug.
Comment 4 Chris Jefferson 2005-02-08 13:24:10 UTC
Yep, that fixed it. Marking it as a dup.

*** This bug has been marked as a duplicate of 12096 ***