Bug 18926 - internal compiler error: in tree_low_cst, at tree.c:3255
Summary: internal compiler error: in tree_low_cst, at tree.c:3255
Status: RESOLVED DUPLICATE of bug 18327
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.3.5
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-10 15:42 UTC by Artur R. Czechowski
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: i486-pc-linux-gnu
Target: i486-pc-linux-gnu
Build: i486-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artur R. Czechowski 2004-12-10 15:42:19 UTC
	
arturcz@blabluga:/tmp/s$ g++ -c foo.c
foo.c:16: internal compiler error: in tree_low_cst, at tree.c:3255
when compiling following code:

---- 8< [cut here] -----------------------------------
typedef struct {
        char *str;
        int n;
        char *(f[]);
        char *(l[]);
        int *a;
} t_moja;


        t_moja x={
                "foobar",
                4,
                {"imie","nazwisko","telefon","email"},
                {"Imiê","Nazwisko","Telefon","E-mail"},
                {0,1,2,3},
        };


        t_moja y={
                "baz",
                2,
                {"dupa","blada"},
                {"Pan","Kowalski"},
                {8,9}
        };

---- 8< [cut here] -----------------------------------

Environment:
System: Linux blabluga.hell.pl 2.6.7bl #1 Sun Jul 4 17:47:48 CEST 2004 i686 GNU/Linux
Architecture: i686

	
host: i486-pc-linux-gnu
build: i486-pc-linux-gnu
target: i486-pc-linux-gnu
configured with: ../src/configure -v --enable-languages=c,c++,java,f77,pascal,objc,ada,treelang --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-gxx-include-dir=/usr/include/c++/3.3 --enable-shared --with-system-zlib --enable-nls --without-included-gettext --enable-__cxa_atexit --enable-clocale=gnu --enable-debug --enable-java-gc=boehm --enable-java-awt=xlib --enable-objc-gc i486-linux

How-To-Repeat:
	Save above snippet into file and run:
	g++ -c filename
Comment 1 Andrew Pinski 2004-12-10 16:08:49 UTC

*** This bug has been marked as a duplicate of 18327 ***