Bug 18563 - ICE: output_operand: invalid expression as operand
Summary: ICE: output_operand: invalid expression as operand
Status: RESOLVED DUPLICATE of bug 18592
Alias: None
Product: gcc
Classification: Unclassified
Component: target (show other bugs)
Version: 3.4.4
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2004-11-19 10:14 UTC by Ralf Corsepius
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host:
Target: avr-rtems*, avr-*
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments
Example to reproduce the ICE (124 bytes, text/plain)
2004-11-19 10:15 UTC, Ralf Corsepius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Corsepius 2004-11-19 10:14:02 UTC
ICE with -O1 or greater, -O0 does not ICE

# avr-rtems4.7-gcc -O4 -o cpuboot.o -c cpuboot.c
cpuboot.c: In function `boot_phase_1':
cpuboot.c:8: internal compiler error: output_operand: invalid expression as operand
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

# avr-rtems4.7-gcc --version
avr-rtems4.7-gcc (GCC) 3.4.4 20041114 (prerelease)

This PR has been split out from
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=18542
Comment 1 Ralf Corsepius 2004-11-19 10:15:35 UTC
Created attachment 7567 [details]
Example to reproduce the ICE
Comment 2 Serge Belyshev 2004-12-07 00:15:36 UTC

*** This bug has been marked as a duplicate of 18542 ***
Comment 3 Ralf Corsepius 2004-12-16 05:35:46 UTC
I am reopening this PR to allow tracking this problem independent of PR18542.

Comment 4 Andrew Pinski 2004-12-16 05:48:12 UTC
No this is a dup of bug 18592, the example code might be different but the bug is the same.

*** This bug has been marked as a duplicate of 18592 ***
Comment 5 Ralf Corsepius 2004-12-16 08:44:27 UTC
WTH are you permantently closing this PR?

This PR is addressing the h8300 and one of the m68k-maintainers (Bernardo) had
explicitly requested me to split the h8300-case from the m68k.

Upset, Ralf