Bug 18491 - testsuite failure: WARNING: g++.old-deja/g++.mike/p10769a.C compilation failed to produce executable
Summary: testsuite failure: WARNING: g++.old-deja/g++.mike/p10769a.C compilation faile...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: testsuite (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: 4.0.0
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 19996 20002 (view as bug list)
Depends on:
Blocks: 19745
  Show dependency treegraph
 
Reported: 2004-11-14 22:52 UTC by Hans-Peter Nilsson
Modified: 2005-06-05 07:38 UTC (History)
2 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: mmix-knuth-mmixware
Build:
Known to work:
Known to fail:
Last reconfirmed: 2004-11-14 22:56:37


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Peter Nilsson 2004-11-14 22:52:12 UTC
With LAST_UPDATED: "Sun Nov 14 05:49:38 UTC 2004" I get:
WARNING: g++.old-deja/g++.mike/p10769a.C compilation failed to produce
executable
(no FAIL/PASS/XFAIL/XPASS though)

With the message in the .log being:
/gcc/testsuite/g++.old-deja/g++.mike/p10769a.C: In member function 'void
A::main()':
/gcc/testsuite/g++.old-deja/g++.mike/p10769a.C:35: error: invalid use of member
(did you forget the '&' ?)
/gcc/testsuite/g++.old-deja/g++.mike/p10769a.C: In function 'int main()':
/gcc/testsuite/g++.old-deja/g++.mike/p10769a.C:44: error: invalid use of member
(did you forget the '&' ?)

Last known to work (no WARNING) on: "Wed Apr 30 23:42:54 GMT 2003".
Known to fail on: "Fri May 2 01:49:20 GMT 2003".

The test also fails on cris-axis-linux-gnu with "Thu May 1 18:50:13 GMT 2003".

Looking at the test, I wonder how this can pass on any target.  It seems
fallout from the testsuite conversion at that time; it shouldn't be "run",
just "compile".
Comment 1 Hans-Peter Nilsson 2004-11-14 22:53:17 UTC
By "failing" I mean "has the warning".  Apparently it's not logged as a failure.
Comment 2 Andrew Pinski 2004-11-14 22:56:37 UTC
It also fails on ppc-darwin:
<http://gcc.gnu.org/ml/gcc-testresults/2004-11/msg00616.html>:
WARNING: g++.old-deja/g++.mike/p10769a.C compilation failed to produce executable

And x86_64-linux-gnu:
<http://gcc.gnu.org/ml/gcc-testresults/2004-11/msg00629.html>

Confirmed.
Comment 3 Hans-Peter Nilsson 2005-02-02 03:34:09 UTC
Also part of PR 19745.
Comment 4 CVS Commits 2005-02-09 23:35:33 UTC
Subject: Bug 18491

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	janis@gcc.gnu.org	2005-02-09 23:35:19

Modified files:
	gcc/testsuite  : ChangeLog 
Removed files:
	gcc/testsuite/g++.old-deja/g++.mike: p10769a.C 

Log message:
	PR C++/18491
	* g++.old-deja/g++.mike/p10769a.C: Remove.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&r1=1.5010&r2=1.5011
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/g++.old-deja/g++.mike/p10769a.C.diff?cvsroot=gcc&r1=1.9&r2=NONE

Comment 5 Janis Johnson 2005-02-09 23:39:53 UTC
See the thread at http://gcc.gnu.org/ml/gcc/2005-02/msg00257.html.             
                   
Comment 6 Zack Weinberg 2005-02-09 23:58:28 UTC
There is also p10769b.C (in the same directory) with exactly the same dubious
construct, this time marked as should-give-an-error.  Do we want to keep that one?
Comment 7 Andrew Pinski 2005-02-16 06:19:06 UTC
*** Bug 19996 has been marked as a duplicate of this bug. ***
Comment 8 Andrew Pinski 2005-02-16 14:14:12 UTC
*** Bug 20002 has been marked as a duplicate of this bug. ***
Comment 9 Hans-Peter Nilsson 2005-02-27 14:39:51 UTC
It's about time to close this one, the test-case being removed and all...
Comment 10 Kaveh Ghazi 2005-12-02 02:12:19 UTC
Subject: Bug 18491

Author: ghazi
Date: Fri Dec  2 02:12:15 2005
New Revision: 107860

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=107860
Log:
2005-12-01  Kaveh R. Ghazi  <ghazi@caip.rutgers.edu>

       Backport:
       2005-02-09  Janis Johnson  <janis187@us.ibm.com>

       PR C++/18491
       * g++.old-deja/g++.mike/p10769a.C: Remove.


Removed:
    branches/gcc-3_4-branch/gcc/testsuite/g++.old-deja/g++.mike/p10769a.C
Modified:
    branches/gcc-3_4-branch/gcc/testsuite/ChangeLog