Bug 17586 - [4.0 regression] kawa build fails with ICE
Summary: [4.0 regression] kawa build fails with ICE
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: 4.0.0
Assignee: Andrew Haley
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks: 17574
  Show dependency treegraph
 
Reported: 2004-09-21 16:05 UTC by Tom Tromey
Modified: 2005-07-23 22:49 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Tromey 2004-09-21 16:05:31 UTC
cvs trunk gcj fails with ICE while building cvs kawa:

 gcj -g -I../../.. -I../../../../kawa/gnu/kawa/functions/../../.. -c
../../../../kawa/gnu/kawa/functions/AddOp.java
../../../../kawa/gnu/kawa/functions/AppendValues.java
../../../../kawa/gnu/kawa/functions/Apply.java
../../../../kawa/gnu/kawa/functions/Arrays.java
../../../../kawa/gnu/kawa/functions/ArrayRef.java
../../../../kawa/gnu/kawa/functions/ArraySet.java
../../../../kawa/gnu/kawa/functions/BaseUri.java
../../../../kawa/gnu/kawa/functions/ConstantFunction0.java
../../../../kawa/gnu/kawa/functions/Convert.java
../../../../kawa/gnu/kawa/functions/CountValues.java
../../../../kawa/gnu/kawa/functions/DisplayFormat.java
../../../../kawa/gnu/kawa/functions/DivideOp.java
../../../../kawa/gnu/kawa/functions/IntegerFormat.java
../../../../kawa/gnu/kawa/functions/IsEq.java
../../../../kawa/gnu/kawa/functions/IsEqual.java
../../../../kawa/gnu/kawa/functions/IsEqv.java
../../../../kawa/gnu/kawa/functions/MakeList.java
../../../../kawa/gnu/kawa/functions/MakeProcedure.java ../../..
 /../kawa/gnu/kawa/functions/MultiplyOp.java
../../../../kawa/gnu/kawa/functions/NumberCompare.java
../../../../kawa/gnu/kawa/functions/Setter.java
../../../../kawa/gnu/kawa/functions/ValuesMap.java
../../../../kawa/gnu/kawa/functions/ObjectFormat.java
../../../../kawa/gnu/kawa/functions/LispFormat.java
../../../../kawa/gnu/kawa/functions/ParseFormat.java
../../../../kawa/gnu/kawa/functions/Format.java  -fPIC -o
../../../bin/.libs/gnu-kawa-functions.o
../../../../kawa/gnu/kawa/functions/ObjectFormat.java: In class
`gnu.kawa.functions.ObjectFormat':
../../../../kawa/gnu/kawa/functions/ObjectFormat.java: In method
`gnu.kawa.functions.ObjectFormat.print(java.lang.Object,gnu.mapping.OutPort,boolean)':
../../../../kawa/gnu/kawa/functions/ObjectFormat.java:75: internal compiler
error: in size_binop, at fold-const.c:1617
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
Comment 1 Andrew Pinski 2004-09-22 03:58:41 UTC
I think this is likely related to PR 15888.
Comment 2 Tom Tromey 2004-09-23 00:42:11 UTC
FWIW this doesn't appear to be like PR 15888.
It has a notably different stack trace:

(gdb) bt
#0  internal_error (msgid=0x85cf507 "in %s, at %s:%d")
    at ../../gcc/gcc/diagnostic.c:543
#1  0x0822cfee in fancy_abort (file=0x85d8133 "../../gcc/gcc/fold-const.c", 
    line=1617, function=0x85d8538 "size_binop")
    at ../../gcc/gcc/diagnostic.c:591
#2  0x0829f494 in size_binop (code=MULT_EXPR, arg0=0xf6ddb4b0, 
    arg1=0xf6ddd1b0) at ../../gcc/gcc/fold-const.c:1616
#3  0x08483bb0 in bit_from_pos (offset=0x0, bitpos=0x0)
    at ../../gcc/gcc/stor-layout.c:542
#4  0x08494554 in bit_position (field=0xf6ccbe80) at ../../gcc/gcc/tree.c:1349
#5  0x0824034e in field_byte_offset (decl=0xf6ccbe80)
    at ../../gcc/gcc/dwarf2out.c:9300
#6  0x08240691 in add_data_member_location_attribute (die=0xf5a8d57c, 
    decl=0xf6ccbe80) at ../../gcc/gcc/dwarf2out.c:9468
#7  0x082449ca in gen_field_die (decl=0xf6ccbe80, context_die=0xf5a874ac)
    at ../../gcc/gcc/dwarf2out.c:11606
#8  0x0824730c in gen_decl_die (decl=0xf6ccbe80, context_die=0xf5a874ac)
    at ../../gcc/gcc/dwarf2out.c:12634
#9  0x08244fc1 in gen_member_die (type=0xf6ce7e80, context_die=0xf5a874ac)
    at ../../gcc/gcc/dwarf2out.c:11806
#10 0x082454a8 in gen_struct_or_union_type_die (type=0xf6ce7e80, 
    context_die=0xf5a87410) at ../../gcc/gcc/dwarf2out.c:11883
#11 0x08246002 in gen_type_die (type=0xf6ce7e80, context_die=0xf5a87410)
    at ../../gcc/gcc/dwarf2out.c:12099
#12 0x08245afd in gen_type_die (type=0xf6ccb000, context_die=0xf5a87410)
    at ../../gcc/gcc/dwarf2out.c:12013
#13 0x08247200 in gen_decl_die (decl=0xf6c62f68, context_die=0xf5a87410)
    at ../../gcc/gcc/dwarf2out.c:12605
#14 0x082465a9 in decls_for_scope (stmt=0xf5a87c64, context_die=0xf5a87410, 
    depth=3) at ../../gcc/gcc/dwarf2out.c:12292
#15 0x082446d3 in gen_lexical_block_die (stmt=0xf5a87c64, 
    context_die=0xf5a87208, depth=3) at ../../gcc/gcc/dwarf2out.c:11534
#16 0x082463af in gen_block_die (stmt=0xf5a87c64, context_die=0xf5a87208, 
    depth=3) at ../../gcc/gcc/dwarf2out.c:12255
#17 0x08246618 in decls_for_scope (stmt=0xf5a87bfc, context_die=0xf5a87208, 
    depth=2) at ../../gcc/gcc/dwarf2out.c:12304
#18 0x082446d3 in gen_lexical_block_die (stmt=0xf5a87bfc, 
    context_die=0xf5a8716c, depth=2) at ../../gcc/gcc/dwarf2out.c:11534
#19 0x082463af in gen_block_die (stmt=0xf5a87bfc, context_die=0xf5a8716c, 
    depth=2) at ../../gcc/gcc/dwarf2out.c:12255
#20 0x08246618 in decls_for_scope (stmt=0xf5a87bc8, context_die=0xf5a8716c, 
    depth=1) at ../../gcc/gcc/dwarf2out.c:12304
#21 0x082446d3 in gen_lexical_block_die (stmt=0xf5a87bc8, 
    context_die=0xf5a872a4, depth=1) at ../../gcc/gcc/dwarf2out.c:11534
#22 0x082463af in gen_block_die (stmt=0xf5a87bc8, context_die=0xf5a872a4, 
    depth=1) at ../../gcc/gcc/dwarf2out.c:12255
#23 0x08246618 in decls_for_scope (stmt=0xf63015e4, context_die=0xf5a872a4, 
    depth=0) at ../../gcc/gcc/dwarf2out.c:12304
#24 0x08243e9d in gen_subprogram_die (decl=0xf6c62984, context_die=0xf6de30d0)
    at ../../gcc/gcc/dwarf2out.c:11365
#25 0x08247036 in gen_decl_die (decl=0xf6c62984, context_die=0xf6de30d0)
    at ../../gcc/gcc/dwarf2out.c:12563
#26 0x08247829 in dwarf2out_decl (decl=0xf6c62984)
    at ../../gcc/gcc/dwarf2out.c:12858
#27 0x084c7443 in rest_of_handle_final () at ../../gcc/gcc/passes.c:340
#28 0x084c9b80 in rest_of_compilation () at ../../gcc/gcc/passes.c:1834
#29 0x0812f3ac in execute_one_pass (pass=0x8644ba0)
    at ../../gcc/gcc/tree-optimize.c:501
#30 0x0812f498 in execute_pass_list (pass=0x8644ba0)
    at ../../gcc/gcc/tree-optimize.c:536
#31 0x0812f754 in tree_rest_of_compilation (fndecl=0xf6c62984, 
    nested_p=0 '\0') at ../../gcc/gcc/tree-optimize.c:636
#32 0x080c928a in java_expand_body (fndecl=0xf6c62984)
    at ../../gcc/gcc/java/decl.c:1967
#33 0x084f80a7 in cgraph_expand_function (node=0xf59c3414)
    at ../../gcc/gcc/cgraphunit.c:1044
#34 0x084f6edc in cgraph_assemble_pending_functions ()
    at ../../gcc/gcc/cgraphunit.c:526
#35 0x084f7097 in cgraph_finalize_function (decl=0xf6c62984, nested=0 '\0')
    at ../../gcc/gcc/cgraphunit.c:609
#36 0x080c9272 in finish_method (fndecl=0xf6c62984)
    at ../../gcc/gcc/java/decl.c:1959
#37 0x080705e9 in source_end_java_method () at parse.y:7532
#38 0x08073719 in java_expand_method_bodies (class=0xf6c60000) at parse.y:8172
#39 0x08078677 in java_expand_classes () at parse.y:9141
#40 0x080ed63d in java_parse_file (set_yydebug=0)
    at ../../gcc/gcc/java/jcf-parse.c:1148
#41 0x0848d660 in compile_file () at ../../gcc/gcc/toplev.c:991
#42 0x0848f089 in do_compile () at ../../gcc/gcc/toplev.c:2079
#43 0x0848f0f0 in toplev_main (argc=22, argv=0xfee94034)
    at ../../gcc/gcc/toplev.c:2111
#44 0x081080d2 in main (argc=22, argv=0xfee94034) at ../../gcc/gcc/main.c:35
Comment 3 Andrew Haley 2004-09-24 15:11:58 UTC
Mine.
Comment 4 CVS Commits 2004-09-28 13:57:20 UTC
Subject: Bug 17586

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	aph@gcc.gnu.org	2004-09-28 13:57:07

Modified files:
	gcc/java       : ChangeLog jcf-parse.c 

Log message:
	2004-09-28  Andrew Haley  <aph@redhat.com>
	
	PR java/17586
	* jcf-parse.c (load_class): Don't try to read a class that we've
	already read.
	Check that we really did read the right class.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/ChangeLog.diff?cvsroot=gcc&r1=1.1465&r2=1.1466
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/jcf-parse.c.diff?cvsroot=gcc&r1=1.169&r2=1.170

Comment 5 Andrew Haley 2004-09-28 14:29:48 UTC
.
Comment 6 Andrew Pinski 2004-09-28 16:44:33 UTC
Reopening because the patch was reverted.
Comment 7 CVS Commits 2004-09-28 17:41:17 UTC
Subject: Bug 17586

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	aph@gcc.gnu.org	2004-09-28 17:40:58

Modified files:
	gcc/java       : jcf-parse.c ChangeLog 

Log message:
	2004-09-28  Andrew Haley  <aph@redhat.com>
	
	PR java/17586
	* jcf-parse.c (load_class): Don't try to read a class that we've
	already read.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/jcf-parse.c.diff?cvsroot=gcc&r1=1.171&r2=1.172
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/java/ChangeLog.diff?cvsroot=gcc&r1=1.1467&r2=1.1468

Comment 8 Andrew Pinski 2004-09-28 18:05:35 UTC
Fixed.