Bug 17574 - [meta-bug] gcj and libgcj 4.0 tracking PR
Summary: [meta-bug] gcj and libgcj 4.0 tracking PR
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: java (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: 4.0.3
Assignee: Not yet assigned to anyone
URL:
Keywords: meta-bug
Depends on: 18190 18266 18399 13468 13720 13948 15223 15475 15575 15576 15578 15656 15710 15888 16789 16927 17007 17222 17265 17311 17329 17380 17500 17586 17587 17689 18222 18796 19295 19505 20155
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 22:05 UTC by Tom Tromey
Modified: 2005-10-25 15:01 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-06-22 00:19:59


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Tromey 2004-09-20 22:05:36 UTC
This is a tracking PR used to indicate what bugs
we are looking at for 4.0.
There is no guarantee that all dependencies of this will
in fact be fixed.
If you add a bug to the list, please provide a justification.
Comment 1 Tom Tromey 2004-09-20 22:19:56 UTC
PR 16927 is a regression
Comment 2 Tom Tromey 2004-09-20 22:21:37 UTC
PR 15575 is a regression.
This worked at some point in the past.
Also, there is a patch pending.

Comment 3 Tom Tromey 2004-09-20 22:24:58 UTC
PR 15475 is a longstanding regression.
Comment 4 Tom Tromey 2004-09-20 22:31:07 UTC
PR 15710: not being able to build ant is a major problem.
PR 15888: building jacorb is "very nice to have"; also resembles PR 17329
PR 17329: not building rhug is a regression

Comment 5 Tom Tromey 2004-09-20 22:34:34 UTC
PR 17007: someone should look at this patch
Comment 6 Tom Tromey 2004-09-20 23:10:10 UTC
PR 7305: A ".0" release is a good time to think about rearranging the install tree
Comment 7 Tom Tromey 2004-09-20 23:36:26 UTC
PR 13720: someone should look at this patch
Comment 8 Tom Tromey 2004-09-20 23:38:21 UTC
PR 13948: similar to some other regressions
Comment 9 Tom Tromey 2004-09-21 16:07:53 UTC
PR 17586: kawa must build
PR 17587: mauve must build
Comment 10 Tom Tromey 2004-09-21 16:33:43 UTC
PR 15223: similar to other ICE PRs; at least investigate
PR 15576: regression (but perhaps intentional)
PR 15656: I still can't reproduce, probably easy
PR 17265: regression
PR 17311: review the patches
PR 17380: regression
Comment 11 Tom Tromey 2004-09-21 22:26:43 UTC
PR 16789: alias for PR 15475
Comment 12 Tom Tromey 2004-09-22 00:13:42 UTC
Investigate this jar failure
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=74106
Comment 13 Tom Tromey 2004-09-23 00:49:58 UTC
PR 15578: probably trivial, at least the "=" part.

Comment 14 Andrew Haley 2004-09-23 12:14:22 UTC
PR 17222: libgcj doesn't build on several targets due to command line length issues.
Comment 15 Tom Tromey 2004-09-23 23:40:56 UTC
FYI, I checked in a fix for the jar failure.
Comment 16 Tom Tromey 2004-09-24 16:06:55 UTC
PR 17500: now prevents rhug from building
Comment 17 Tom Tromey 2004-09-24 21:36:43 UTC
PR 14664: regression; nothing works on alpha
Comment 18 Tom Tromey 2004-10-14 22:47:32 UTC
PR 13468: stack trace regression (one patch is on BC branch already)
Comment 19 Bryce McKinlay 2004-10-20 21:41:11 UTC
Removing PR 14664 because its fixed on the 4.0 trunk.
Comment 20 Tom Tromey 2004-11-25 03:26:18 UTC
18266: low-level bug in Reference code; this is used by
  many real applications
Comment 21 Andrew Pinski 2004-11-27 02:39:01 UTC
Only one regression left here: PR 18399.
Comment 22 Tom Tromey 2005-01-10 23:37:52 UTC
Added more regression PRs
Comment 23 Mark Mitchell 2005-01-19 18:52:01 UTC
Ada and Java bugs are not release-critical; therefore, I've removed the target
milsetone.
Comment 24 Tom Tromey 2005-09-27 19:48:03 UTC
There seems little point in leaving this open now that 4.0 has shipped.
Any required patches should be mentioned in bug #24018