GCC Bugzilla has been upgraded from version 4.4.9 to 5.0rc3. If you see any problem, please report it to bug 64968.
Bug 17497 - [4.0 Regression] ICE: "address taken, but ADDRESSABLE bit not set"
Summary: [4.0 Regression] ICE: "address taken, but ADDRESSABLE bit not set"
Status: RESOLVED DUPLICATE of bug 17483
Alias: None
Product: gcc
Classification: Unclassified
Component: tree-optimization (show other bugs)
Version: 4.0.0
: P2 critical
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 17498 (view as bug list)
Depends on:
Blocks: 8361
  Show dependency treegraph
 
Reported: 2004-09-15 09:48 UTC by Gerald Pfeifer
Modified: 2004-09-15 10:12 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2004-09-15 09:58:09


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2004-09-15 09:48:59 UTC
Compile generate-3.4.ii with -O3 on current mainline, and you'll get:

  %gccvs -O3 generate-3.4.ii 
  generate.C: In member function `bool MODEL_GENERATOR::propagateGUS(const
COMPONENT_INDEX&, GINTERPRET&)':
  generate.C:1362: error: address taken, but ADDRESSABLE bit not set iD.328848
  generate.C:1362: error: address taken, but ADDRESSABLE bit not set iD.328848
  generate.C:1362: error: address taken, but ADDRESSABLE bit not set iD.329397
  generate.C:1362: error: address taken, but ADDRESSABLE bit not set iD.329397
  generate.C:1362: internal compiler error: verify_stmts failed.
Comment 1 Gerald Pfeifer 2004-09-15 09:50:24 UTC
*** Bug 17498 has been marked as a duplicate of this bug. ***
Comment 2 Steven Bosscher 2004-09-15 09:58:08 UTC
The test case is the same as that of Bug 8361.
Comment 3 Andrew Pinski 2004-09-15 10:12:56 UTC
This is a dup of bug 17483.

*** This bug has been marked as a duplicate of 17483 ***