User account creation filtered due to spam.

Bug 17478 - [4.0 regression] ICE in verify_stmts
Summary: [4.0 regression] ICE in verify_stmts
Status: RESOLVED DUPLICATE of bug 17483
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 4.0.0
: P2 critical
Target Milestone: 4.0.0
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on: 17483
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 14:18 UTC by Wolfgang Bangerth
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail: 4.0.0
Last reconfirmed:


Attachments
preprocessed sources (155.40 KB, application/x-gzip)
2004-09-14 14:20 UTC, Wolfgang Bangerth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Bangerth 2004-09-14 14:18:42 UTC
With the code I'm going to attach in a second, I get this: 
 
spec/src> c++ -O3 -c sparse_matrix.double.ii  
include/lac/sparse_matrix.h: In member function `typename 
SparseMatrix<number>::const_iterator SparseMatrix<number>::begin() const [with 
number = double]': 
include/lac/sparse_matrix.h:2126: error: address taken, but ADDRESSABLE bit 
not set 
D.113567 
 
include/lac/sparse_matrix.h:2126: internal compiler error: verify_stmts 
failed. 
Please submit a full bug report, 
with preprocessed source if appropriate. 
See <URL:http://gcc.gnu.org/bugs.html> for instructions. 
 
W.
Comment 1 Wolfgang Bangerth 2004-09-14 14:20:41 UTC
Created attachment 7129 [details]
preprocessed sources

Unreduced sources. I won't have time to reduce them for a while, so if
someone wants to beat me to it, I'd be happy.

W.
Comment 2 Wolfgang Bangerth 2004-09-14 14:21:29 UTC
Forgot to say, this is with yesterday's CVS. 
W. 
Comment 3 Giovanni Bajo 2004-09-14 14:23:04 UTC
BTW, we should not emit this stuff with error(), but rather internal_error() 
because this way it seems a normal diagnostic.
Comment 4 Andrew Pinski 2004-09-14 16:22:01 UTC
This is more likely a front-end problem rather than a tree-optimization problem.
Comment 5 Andrew Pinski 2004-09-14 20:41:44 UTC
This is most likely a dup of bug 17483.
Comment 6 Andrew Pinski 2004-09-14 21:56:53 UTC
Yes this is a dup of bug 17483.

*** This bug has been marked as a duplicate of 17483 ***