Bug 17446 - too few template-parameter-lists
Summary: too few template-parameter-lists
Status: RESOLVED DUPLICATE of bug 17445
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.4.1
: P1 critical
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-13 00:40 UTC by carlson14
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: alphaev67-dec-osf5.1
Target: alphaev67-dec-osf5.1
Build: alphaev67-dec-osf5.1
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description carlson14 2004-09-13 00:40:26 UTC
The following code give this error (compiles fine in 3.3.3):
I don't know if I need to fix my code, or if it is a bug
in 3.4.1.

test.cpp:10: error: too few template-parameter-lists
test.cpp:10: error: expected `,' or `;' before '=' token

template <class T> class MyType {
public:
 static char *name;
};
 
class Sample {
};
 
MyType<Sample> list;
char *MyType<Sample>::name = "Hello\n";
 
 
int main(int argc, char **argv) {
}
Comment 1 Andrew Pinski 2004-09-13 01:03:16 UTC

*** This bug has been marked as a duplicate of 17445 ***