Bug 17292 - gst-plugins-ffmpeg version 0.8.0 fail to specific options
Summary: gst-plugins-ffmpeg version 0.8.0 fail to specific options
Status: RESOLVED DUPLICATE of bug 17291
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 3.3.4
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-02 18:20 UTC by Francisco Javier Felix
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Javier Felix 2004-09-02 18:20:13 UTC
ffmpeg single compiles incorrectly with the following options:

-os
-falign-functions
-fforce-addr

Show de report

 /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/cc1 -fpreprocessed dsputil_mmx.i
-quiet -dumpbase dsputil_mmx.c -msse -auxbase dsputil_mmx -version
-falign-functions=4 -fforce-addr -o dsputil_mmx.s
GNU C version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)
(i686-pc-linux-gnu)
	compiled by GNU C version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2,
pie-8.7.6).
GGC heuristics: --param ggc-min-expand=64 --param ggc-min-heapsize=64493
dsputil_mmx.c: In function `h263_h_loop_filter_mmx':
dsputil_mmx.c:614: error: can't find a register in class `GENERAL_REGS' while
reloading `asm'
Comment 1 Andrew Pinski 2004-09-02 18:22:40 UTC

*** This bug has been marked as a duplicate of 17291 ***