Bug 17259 - One more _S_leaf incorrectly qualified with _RopeRep:: in ropeimpl.h
Summary: One more _S_leaf incorrectly qualified with _RopeRep:: in ropeimpl.h
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libstdc++ (show other bugs)
Version: 3.4.2
: P2 minor
Target Milestone: 3.4.3
Assignee: Benjamin Kosnik
URL:
Keywords:
: 17914 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-09-01 03:24 UTC by Leland Wang
Modified: 2004-10-09 20:20 UTC (History)
2 users (show)

See Also:
Host: i386-unknown-freebsd5.3
Target: i386-unknown-freebsd5.3
Build: i386-unknown-freebsd5.3
Known to work:
Known to fail:
Last reconfirmed: 2004-09-01 05:08:29


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leland Wang 2004-09-01 03:24:20 UTC
After the committing of reversion 1.23.4.5 of
gcc/libstdc++-v3/include/ext/ropeimpl.h on Fri Jun 18 10:28:08 2004 UTC,
_S_leaf, _S_function, etc have been qualified with _Rope_constants:: instead of
_RopeRep.
However, there is one left out. Searching for _RopeRep::_S_leaf in ropeimpl.h
and there is one match. This causes sources which include ext/ropeimpl.h fail to
build.
Comment 1 Andrew Pinski 2004-09-01 05:08:27 UTC
Confirmed:
    rope<_CharT, _Alloc>::
    _S_compare (const _RopeRep* __left, const _RopeRep* __right)
    {
.....
      if (_Rope_constants::_S_leaf == __left->_M_tag)
        {
....
          if (_RopeRep::_S_leaf == __right->_M_tag)
Comment 2 Benjamin Kosnik 2004-09-02 18:01:36 UTC
Mine.
Comment 3 CVS Commits 2004-09-02 18:22:29 UTC
Subject: Bug 17259

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	bkoz@gcc.gnu.org	2004-09-02 18:22:21

Modified files:
	libstdc++-v3   : ChangeLog 
	libstdc++-v3/include/ext: ropeimpl.h 

Log message:
	2004-09-02  Benjamin Kosnik  <bkoz@redhat.com>
	Leland Wang  <llwang@infor.org>
	
	PR libstdc++/17259
	* include/ext/ropeimpl.h (rope::_S_compare): Use
	_Rope_constants::_S_leaf.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&r1=1.2651&r2=1.2652
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/include/ext/ropeimpl.h.diff?cvsroot=gcc&r1=1.30&r2=1.31

Comment 4 CVS Commits 2004-09-08 13:36:14 UTC
Subject: Bug 17259

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	bkoz@gcc.gnu.org	2004-09-08 13:36:07

Modified files:
	libstdc++-v3/include/ext: ropeimpl.h 
	libstdc++-v3   : ChangeLog 

Log message:
	2004-09-08  Benjamin Kosnik  <bkoz@redhat.com>
	Leland Wang  <llwang@infor.org>
	
	PR libstdc++/17259
	* include/ext/ropeimpl.h (rope::_S_compare): Use
	_Rope_constants::_S_leaf.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/include/ext/ropeimpl.h.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.23.4.5&r2=1.23.4.6
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.2224.2.170&r2=1.2224.2.171

Comment 5 Andrew Pinski 2004-09-09 17:08:10 UTC
Fixed in 3.4.3.
Comment 6 Andrew Pinski 2004-10-09 20:20:24 UTC
*** Bug 17914 has been marked as a duplicate of this bug. ***