Bug 17094 - [m32r-*-gcc] ICE with -msdata=use -O0
Summary: [m32r-*-gcc] ICE with -msdata=use -O0
Status: RESOLVED DUPLICATE of bug 17093
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 3.4.2
: P2 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-19 06:57 UTC by inaoka.kazuhiro
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host:
Target: m32r
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description inaoka.kazuhiro 2004-08-19 06:57:21 UTC
-- sdata.c --
extern char *name;
main()
{
        printf("%s\n",name);
}

 m32r-elf-gcc -c -msdata=use -O0 sdata.c

sdata.c: In function `main':
sdata.c:5: error: unrecognizable insn:
(insn 8 21 9 0 (set (reg:SI 27)
        (unspec [
                (const_int 0 [0x0])
            ] 2)) -1 (nil)
    (nil))
sdata.c:5: internal compiler error: in extract_insn, at recog.c:2083
Comment 1 Andrew Pinski 2004-08-19 18:58:30 UTC

*** This bug has been marked as a duplicate of 17093 ***

*** This bug has been marked as a duplicate of 17093 ***