Bug 17054 - internal compiler error: in make_decl_rtl, at varasm.c:752
Summary: internal compiler error: in make_decl_rtl, at varasm.c:752
Status: RESOLVED DUPLICATE of bug 15461
Alias: None
Product: gcc
Classification: Unclassified
Component: c++ (show other bugs)
Version: 3.4.1
: P3 minor
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code
Depends on:
Blocks:
 
Reported: 2004-08-16 23:17 UTC by Tarabiscote
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tarabiscote 2004-08-16 23:17:02 UTC
Well it's easy to make the prog work, but I still report it

To reproduce :

typedef struct tagS {
	long a;
	long b;
	long c;
} S;

int i;
S g(const S &);
S g();

int f()
{
    return 0;
}

S g(const S &toto)
{ // the error is here
	int h = f();
	S tata = {toto.a, toto.b, h};
	return tata;
}

S g()
{
	S toto;
	return g(toto);
}
Comment 1 Andrew Pinski 2004-08-17 00:15:44 UTC

*** This bug has been marked as a duplicate of 15461 ***