Bug 16566 - [3.4 Regression] ICE with flexible arrays
Summary: [3.4 Regression] ICE with flexible arrays
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: c (show other bugs)
Version: 3.4.1
: P2 normal
Target Milestone: 3.4.3
Assignee: Not yet assigned to anyone
URL:
Keywords: ice-on-valid-code, monitored
: 16575 (view as bug list)
Depends on:
Blocks: 16989
  Show dependency treegraph
 
Reported: 2004-07-15 14:16 UTC by Patrick Pelissier
Modified: 2004-09-23 15:59 UTC (History)
3 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work: 3.2.3 3.3.4 4.0.0
Known to fail: 3.4.0
Last reconfirmed: 2004-08-24 16:45:51


Attachments
The preprocessed file (12.78 KB, application/octet-stream)
2004-07-15 14:17 UTC, Patrick Pelissier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Pelissier 2004-07-15 14:16:21 UTC
I have had this bug with differents GCC releases:

Reading specs from /usr/lib/gcc-lib/i486-linux/3.3.4/specs
Configured with: ../src/configure -v
--enable-languages=c,c++,java,f77,pascal,objc,ada,treelang --prefix=/usr
--mandir=/usr/share/man --infodir=/usr/share/info
--with-gxx-include-dir=/usr/include/c++/3.3 --enable-shared --with-system-zlib
--enable-nls --without-included-gettext --enable-__cxa_atexit
--enable-clocale=gnu --enable-debug --enable-java-gc=boehm
--enable-java-awt=xlib --enable-objc-gc i486-linux
Thread model: posix
gcc version 3.3.4 (Debian)

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2.3/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit --enable-languages=c
--disable-libgcj --host=i386-redhat-linux
Thread model: posix
gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-6)

Reading specs from /global/morpork/gcc-3.4/lib/gcc/i686-pc-linux-gnu/3.4.1/specs
Configured with: ./configure --prefix=/global/morpork/gcc-3.4
Thread model: posix
gcc version 3.4.1

It seems to work fine with:
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.3.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit --host=i386-redhat-linux
Thread model: posix
gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1)

Here are the ouput with GCC 3.4.1:

morpork may 58 % /global/morpork/gcc-3.4/bin/gcc -I.
-I/users/spaces/logiciels/mpfr-2.0.2/k7//include
-I/users/spaces/logiciels/gmp-4.1.2/k7//include -g -DWANT_ASSERT -Wall
-Wmissing-prototypes -c dump.c -save-temps
dump.c: In function `may_dump_rec':
dump.c:51: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

This has been tested on different systems too (P3, P4, athlon and amd64).
Comment 1 Patrick Pelissier 2004-07-15 14:17:51 UTC
Created attachment 6753 [details]
The preprocessed file
Comment 2 Andrew Pinski 2004-07-15 14:41:23 UTC
On the mainline I do not get a seg fault but a normal ICE:
pr16566.c: In function `may_dump_rec':
pr16566.c:3565: internal compiler error: in create_tmp_var, at gimplify.c:358
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
Comment 3 Wolfgang Bangerth 2004-07-15 15:42:34 UTC
Confirmed: 
------------------------ 
struct S; 
 
struct C { 
    int i; 
    struct S *tab[]; 
}; 
 
struct S { struct C c; }; 
 
void foo (struct S *x) { 
  foo(((void)1, x->c).tab[0]);  
} 
--------------------- 
 
g/x> /home/bangerth/bin/gcc-3.4-pre/bin/gcc -c x.c 
x.c: In function `foo': 
x.c:11: internal compiler error: Segmentation fault 
Please submit a full bug report, 
with preprocessed source if appropriate. 
See <URL:http://gcc.gnu.org/bugs.html> for instructions. 
 
g/x> /home/bangerth/bin/gcc-3.5-pre/bin/gcc -c x.c 
x.c: In function `foo': 
x.c:11: internal compiler error: in create_tmp_var, at gimplify.c:358 
Please submit a full bug report, 
with preprocessed source if appropriate. 
See <URL:http://gcc.gnu.org/bugs.html> for instructions. 
 
 
This used to work with 3.2 and 3.3, so is a regression in 3.4 and mainline. 
 
W. 
Comment 4 Wolfgang Bangerth 2004-07-15 20:24:16 UTC
*** Bug 16575 has been marked as a duplicate of this bug. ***
Comment 5 Volker Reichelt 2004-07-16 00:51:27 UTC
Even shorter example:

=============================
struct A
{
    int i;
    int x[];
};

int foo(struct A a)
{
    return (a,a).x[0];
}
=============================
Comment 6 Andrew Pinski 2004-08-09 00:22:56 UTC
: Search converges between 2003-11-07-trunk (#398) and 2003-11-08-trunk (#399).
Comment 7 Andrew Pinski 2004-08-09 00:25:24 UTC
The only thing during that time period that seems likely is:
2003-11-08  Joseph S. Myers  <jsm@polyomino.org.uk>

        * c-typeck.c (pedantic_lvalue_warning): Deprecate compound
        expressions as lvalues.
        (internal_build_compound_expr): Remove special handling for
        non-pedantic case.
        * doc/extend.texi: Document that all extended lvalues are now
        deprecated.
Comment 8 Andrew Pinski 2004-08-09 00:26:52 UTC
Which looks right as the following is produced:
{
  return (a, NON_LVALUE_EXPR <a.x>)[0];
}
Comment 9 Joseph S. Myers 2004-08-09 11:23:36 UTC
Subject: Re:  [3.4/3.5 Regression] ICE with flexible arrays

Note that this already fails with 3.2.3 if you use -std=c99 -pedantic.

Also note that though the code should be accepted, it has undefined 
behavior if executed; a non-lvalue with structure with flexible array 
member type is a value that does not refer to an object (other than a 
temporary that disappears at the next sequence point), so members of the 
flexible array can't be accessed without undefined behavior.

Comment 10 Mark Mitchell 2004-08-23 21:01:44 UTC
Postponed until GCC 3.4.3.
Comment 13 Andrew Pinski 2004-09-23 15:59:11 UTC
Fixed.