User account creation filtered due to spam.

Bug 16465 - parser chokes with ffixed-line-length-7
Summary: parser chokes with ffixed-line-length-7
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: fortran (show other bugs)
Version: 4.0.0
: P2 minor
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords: rejects-valid
Depends on:
Blocks: 19292
  Show dependency treegraph
 
Reported: 2004-07-10 12:52 UTC by David Billinghurst
Modified: 2006-05-31 05:59 UTC (History)
2 users (show)

See Also:
Host: i686-pc-cygwin
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2006-01-21 02:52:41


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Billinghurst 2004-07-10 12:52:53 UTC
gfortran does not accept the command line arg -ffixed-line-length-72.f,
which is documented in the manual.

Error message is:
f951: error: unrecognized command line option "-fixed-line-length-72.f"
Comment 1 David Billinghurst 2004-07-10 12:54:40 UTC
Cut and paste error.  Does not accept -ffixed-line-length-72

error is:
f951: warning: unknown register name: line-length-72
Comment 2 Tobias Schlüter 2004-07-11 12:31:12 UTC
Patch here: http://gcc.gnu.org/ml/fortran/2004-07/msg00117.html
Comment 3 Andrew Pinski 2004-07-12 04:53:51 UTC
Newest patch: <http://gcc.gnu.org/ml/fortran/2004-07/msg00132.html>.
Comment 4 CVS Commits 2004-07-18 13:00:40 UTC
Subject: Bug 16465

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	tobi@gcc.gnu.org	2004-07-18 13:00:35

Modified files:
	gcc/fortran    : ChangeLog lang.opt options.c scanner.c 

Log message:
	PR fortran/16465
	* lang.opt (ffixed-line-length-none, ffixed-line-length-): New
	options.
	(ffixed-line-length-80, ffixed-line-length-132): Remove.
	* options.c (gfc_handle_options): Deal with changed options.
	* scanner.c (load_line): Change second arg to 'char **',
	allocate if pointing to NULL. Keep track of buffer's length.
	Adapt buffer size to overlong lines. Pad lines to full length
	in fixed form.
	(load_file): Adapt to new interface of load_line.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/fortran/ChangeLog.diff?cvsroot=gcc&r1=1.133&r2=1.134
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/fortran/lang.opt.diff?cvsroot=gcc&r1=1.6&r2=1.7
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/fortran/options.c.diff?cvsroot=gcc&r1=1.7&r2=1.8
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/fortran/scanner.c.diff?cvsroot=gcc&r1=1.6&r2=1.7

Comment 5 CVS Commits 2004-07-18 13:06:37 UTC
Subject: Bug 16465

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	tobi@gcc.gnu.org	2004-07-18 13:06:31

Modified files:
	gcc/testsuite  : ChangeLog 
	gcc/testsuite/gfortran.dg/g77: README 
Added files:
	gcc/testsuite/gfortran.dg/g77: ffixed-line-length-0.f 
	                               ffixed-line-length-132.f 
	                               ffixed-line-length-72.f 
	                               ffixed-line-length-none.f 

Log message:
	PR fortran/16465
	* gfortran.dg/g77//ffixed-line-length-0.f,
	gfortran.dg/g77/ffixed-line-length-132.f,
	gfortran.dg/g77/ffixed-line-length-72.f,
	gfortran.dg/g77/ffixed-line-length-none.f: Copy from g77.dg.
	gfortran.dg/g77/README: Update.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&r1=1.4015&r2=1.4016
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gfortran.dg/g77/ffixed-line-length-0.f.diff?cvsroot=gcc&r1=NONE&r2=1.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gfortran.dg/g77/ffixed-line-length-132.f.diff?cvsroot=gcc&r1=NONE&r2=1.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gfortran.dg/g77/ffixed-line-length-72.f.diff?cvsroot=gcc&r1=NONE&r2=1.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gfortran.dg/g77/ffixed-line-length-none.f.diff?cvsroot=gcc&r1=NONE&r2=1.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gfortran.dg/g77/README.diff?cvsroot=gcc&r1=1.1&r2=1.2

Comment 6 Tobias Schlüter 2004-07-18 13:09:09 UTC
ffixed-line-length-7.f doesn't yet work, this is apparently an issue in the
parser. The testaces looks like this:
       E
      1N
      2D
Comment 7 Toby White 2004-07-22 17:59:45 UTC
(In reply to comment #6) 
> ffixed-line-length-7.f doesn't yet work, this is apparently an issue in the 
> parser. The testaces looks like this: 
>        E 
>       1N 
>       2D 
 
Note that in any case, the standard specifically prohibits breaking a program 
unit END statement over a number of lines in fixed form (See, eg F95 3.3.2.4).  
However, g77 does allow it.  
 
Comment 8 Tobias Schlüter 2004-09-01 14:39:24 UTC
(In reply to comment #7)
> (In reply to comment #6) 
> > ffixed-line-length-7.f doesn't yet work, this is apparently an issue in the 
> > parser. The testaces looks like this: 
> >        E 
> >       1N 
> >       2D 
>  
> Note that in any case, the standard specifically prohibits breaking a program 
> unit END statement over a number of lines in fixed form (See, eg F95 3.3.2.4).  
> However, g77 does allow it.

Just saw this comment, I had forgotten to add myself to the CC list. We have
this problem with all statements, not just END. At the same time we allow
something like
     END
    1PROGRAM

Comment 9 Jerry DeLisle 2006-05-31 05:16:33 UTC
I think we ought to scrap this.  There is no real point to it,is there?
Comment 10 david.billinghurst@comalco.riotinto.com.au 2006-05-31 05:36:20 UTC
Subject: RE:  parser chokes with ffixed-line-length-7

> ------- Comment #9 from jvdelisle at gcc dot gnu dot org  
> 2006-05-31 05:16 -------
> I think we ought to scrap this.  There is no real point to 
> it,is there?
> 

Yes, this is OK with me.  I was just noting difference with g77.
We don't want to support all the wierd "functionality".

	David


NOTICE
This e-mail and any attachments are private and confidential and may contain privileged information. If you are not an authorised recipient, the copying or distribution of this e-mail and any attachments is prohibited and you must not read, print or act in reliance on this e-mail or attachments.
This notice should not be removed.
Comment 11 Jerry DeLisle 2006-05-31 05:59:56 UTC
Closing.