GCC Bugzilla has been upgraded from version 4.4.9 to 5.0rc3. If you see any problem, please report it to bug 64968.
Bug 16436 - gfortran TL edit descriptor failure - test f77-edit-t-in.f
Summary: gfortran TL edit descriptor failure - test f77-edit-t-in.f
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: libfortran (show other bugs)
Version: 4.0.0
: P2 normal
Target Milestone: 4.0.1
Assignee: Francois-Xavier Coudert
URL: http://gcc.gnu.org/ml/fortran/2005-05...
Keywords: patch
: 20236 (view as bug list)
Depends on:
Blocks: 19292
  Show dependency treegraph
 
Reported: 2004-07-08 14:25 UTC by David Billinghurst
Modified: 2005-06-16 22:29 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-05-30 10:51:19


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Billinghurst 2004-07-08 14:25:26 UTC
Test g77.dg/f77-edit-t-in.f fails with a run-time error 

At line 14 of file /usr/local/src/gcc/gcc/testsuite/gfortran.dg/f77-edit-t-in.f
Fortran runtime error: T Or TL edit position error

This code is part of the g77 testsuite.
Comment 1 Bud Davis 2004-07-11 03:53:25 UTC
this problem is in the run-time library.

--bud davis
Comment 2 Toon Moene 2004-09-09 18:47:37 UTC
Also fails on powerpc-unknown-linux-gnu, using gcc-3.5-20040908.
Comment 3 Francois-Xavier Coudert 2005-03-17 22:07:43 UTC
Still present. Minimal testcase is:
      integer i
      character*32 in

      in = '1234   8'
      read(in,'(5X,TL4,I2)') i

I'll work on that one.
Comment 4 Francois-Xavier Coudert 2005-05-30 10:51:19 UTC
I'm beginning to see what happens here. It's arising from many small errors in
the library code (bad handling of "bytes_left" and "active" fields).

I will probably come up with a nice patch in the next few days.
Comment 5 Francois-Xavier Coudert 2005-06-01 09:44:39 UTC
*** Bug 20236 has been marked as a duplicate of this bug. ***
Comment 6 CVS Commits 2005-06-16 22:13:37 UTC
Subject: Bug 16436

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	fxcoudert@gcc.gnu.org	2005-06-16 22:13:26

Modified files:
	gcc/testsuite  : ChangeLog 
	gcc/testsuite/gfortran.dg/g77: f77-edit-t-in.f 
	libgfortran    : ChangeLog 
	libgfortran/io : transfer.c unix.c 

Log message:
	PR libfortran/16436
	* io/transfer.c (read_sf): Correct updating of bytes_left field.
	(formatted_transfer): Correct updating of bytes_left field and
	reformatting code (comments and whitespace).
	* io/unix.c (move_pos_offset): "active" field should not be
	changed here. Whitespace corrections.
	* gfortran.dg/g77/f77-edit-t-in.f: Not XFAIL-ed any more.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&r1=1.5643&r2=1.5644
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gfortran.dg/g77/f77-edit-t-in.f.diff?cvsroot=gcc&r1=1.1&r2=1.2
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libgfortran/ChangeLog.diff?cvsroot=gcc&r1=1.242&r2=1.243
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libgfortran/io/transfer.c.diff?cvsroot=gcc&r1=1.42&r2=1.43
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libgfortran/io/unix.c.diff?cvsroot=gcc&r1=1.27&r2=1.28

Comment 7 CVS Commits 2005-06-16 22:26:16 UTC
Subject: Bug 16436

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-4_0-branch
Changes by:	fxcoudert@gcc.gnu.org	2005-06-16 22:25:41

Modified files:
	gcc/testsuite  : ChangeLog 
	gcc/testsuite/gfortran.dg/g77: f77-edit-t-in.f 
	libgfortran    : ChangeLog 
	libgfortran/io : transfer.c unix.c 

Log message:
	PR libfortran/16436
	* io/transfer.c (read_sf): Correct updating of bytes_left field.
	(formatted_transfer): Correct updating of bytes_left field and
	reformatting code (comments and whitespace).
	* io/unix.c (move_pos_offset): "active" field should not be
	changed here. Whitespace corrections.
	* gfortran.dg/g77/f77-edit-t-in.f: Not XFAIL-ed any more.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=1.5084.2.239&r2=1.5084.2.240
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/gfortran.dg/g77/f77-edit-t-in.f.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=1.1&r2=1.1.48.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libgfortran/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=1.163.2.50&r2=1.163.2.51
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libgfortran/io/transfer.c.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=1.32.2.5&r2=1.32.2.6
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libgfortran/io/unix.c.diff?cvsroot=gcc&only_with_tag=gcc-4_0-branch&r1=1.21.10.5&r2=1.21.10.6

Comment 8 Francois-Xavier Coudert 2005-06-16 22:29:42 UTC
Fixed.