Bug 16250 - ada/doctools runs makeinfo even in release tarball
Summary: ada/doctools runs makeinfo even in release tarball
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.4.1
: P2 normal
Target Milestone: 3.4.2
Assignee: Kelley Cook
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-28 18:14 UTC by Michael Elizabeth Chastain
Modified: 2005-07-23 22:49 UTC (History)
1 user (show)

See Also:
Host: i686-pc-linux-gnu
Target: i686-pc-linux-gnu
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments
output from 'configure' command (292 bytes, text/plain)
2004-06-28 18:16 UTC, Michael Elizabeth Chastain
Details
make file from "make bootstrap" (158.82 KB, application/octet-stream)
2004-06-28 20:41 UTC, Michael Elizabeth Chastain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Elizabeth Chastain 2004-06-28 18:14:00 UTC
This happens with both gcc 3.4.0 and gcc 3.4.1-20040625.

My system is native i686-pc-linux-gnu, red hat 8.0.  I am bootstrapping from gcc
3.3.3 with Ada installed.

The exact commands are:

  /berman/migchain/source/gcc-3.4.1-20040625/configure \
    --prefix=/berman/home.gnu/gcc/pr-makeinfo/install
  make bootstrap

In bootstrap.out, I see makeinfo running:

if [ xinfo = xinfo ]; then \
  rm -f doc/gnat_ugn_unw.info*; \
  makeinfo --split-size=5000000 --no-split
-I/berman/migchain/source/gcc-3.4.1-20040625/gcc/doc/include \
            -I/berman/migchain/source/gcc-3.4.1-20040625/gcc/ada -o
doc/gnat_ugn_unw.info doc/gnat_ugn_unw.texi; \
else true; fi
if [ xinfo = xinfo ]; then \
  rm -f doc/gnat_rm.info*; \
  makeinfo --split-size=5000000 --no-split
-I/berman/migchain/source/gcc-3.4.1-20040625/gcc/doc/include \
            -I/berman/migchain/source/gcc-3.4.1-20040625/gcc/ada -o
doc/gnat_rm.info /berman/migchain/source/gcc-3.4.1-20040625/gcc/ada/gnat_rm.texi; \
else true; fi
if [ xinfo = xinfo ]; then \
  rm -f doc/gnat-style.info*; \
  makeinfo --split-size=5000000 --no-split
-I/berman/migchain/source/gcc-3.4.1-20040625/gcc/doc/include \
            -I/berman/migchain/source/gcc-3.4.1-20040625/gcc/ada -o
doc/gnat-style.info
/berman/migchain/source/gcc-3.4.1-20040625/gcc/ada/gnat-style.texi; \
else true; fi
make[2]: Leaving directory `/berman/home/mec.gnu/gcc/pr-makeinfo/build/gcc'

This shouldn't be happening with a release tarball.

This also happened with gcc 3.4.0, so this is not a regression in gcc
3.4.1-20040625.

I'm attaching the log from 'configure' now, and I'll attach the log from 'make
bootstrap' when it finishes running.
Comment 1 Michael Elizabeth Chastain 2004-06-28 18:16:24 UTC
Created attachment 6641 [details]
output from 'configure' command

output from 'configure' command
I don't think you need this but just in case you do, it's here.
Comment 2 Michael Elizabeth Chastain 2004-06-28 20:41:12 UTC
Created attachment 6643 [details]
make file from "make bootstrap"

Here is the entire log file from "make bootstrap".
You might not need this, but just in case you do, it's here.
Comment 3 Kelley Cook 2004-06-30 15:55:25 UTC
Subject: Re:  [3.4.1 regression] ada/doctools runs makeinfo
 even in release tarball

This patch should fix the problem with the 3.4.1 regression that Michael 
noticed.

It has been tested under 3.4 with i686-pc-cygwin by building with 
--enable-generated-files-in-srcdir
followed by rebuilding in a clean tree from the resultant directory 
without that switch.

The former case does put three ada info files into $(srcdir)/gcc/doc
In the latter case, those same info files, as well as the xgnatugn 
executable and its generated .texi file do not get rebuilt.

OK to install?
Comment 4 Kelley Cook 2004-06-30 15:58:17 UTC
Subject: Re:  [3.4.1 regression] ada/doctools runs makeinfo
 even in release tarball

This patch should fix the problem with the 3.4.1 regression that Michael
noticed.

It has been tested under 3.4 with i686-pc-cygwin by building with
--enable-generated-files-in-srcdir
followed by rebuilding in a clean tree from the resultant directory
without that switch.

The former case does put three ada info files into $(srcdir)/gcc/doc
In the latter case, those same info files, as well as the xgnatugn
executable and its generated .texi file do not get rebuilt.

OK to install?

(D'oh! I'll attach the patch this time)
[contrib]
2004-06-30  Kelley Cook  <kcook@gcc.gnu.org>

	* gcc_update: Add gnat_ugn_unw.texi and gnat_ugn_unw.info.

[gcc/ada]
2004-06-30  Kelley Cook  <kcook@gcc.gnu.org>

	* Make-lang.in (doc/gnat_ugn_unw.texi): Eliminate explicit
	dependency on xgnatugn, instead build it via a submake.
	(ADA_INFOFILES): Add doc/gnat_ugn_unw.texi.

diff -prud gcc-3.4.1-20040625/contrib/gcc_update gcc-3.4.1/contrib/gcc_update
--- gcc-3.4.1-20040625/contrib/gcc_update	2004-06-09 05:15:14.000000000 -0400
+++ gcc-3.4.1/contrib/gcc_update	2004-06-30 09:54:12.892552400 -0400
@@ -67,6 +67,8 @@ gcc/config.in: gcc/cstamp-h.in
 gcc/fixinc/fixincl.x: gcc/fixinc/fixincl.tpl gcc/fixinc/inclhack.def
 # And then, language-specific files
 gcc/f/intdoc.texi: gcc/f/intdoc.in gcc/f/intdoc.c gcc/f/intrin.h gcc/f/intrin.def
+gcc/doc/gnat_ugn_unw.texi: gcc/ada/gnat_ugn.texi gcc/ada/ug_words
+gcc/doc/gnat_ugn_unw.info: gcc/doc/gnat_ugn_unw.texi
 gcc/cp/cfns.h: gcc/cp/cfns.gperf
 gcc/java/keyword.h: gcc/java/keyword.gperf
 # testsuite
diff -prud gcc-3.4.1-20040625/gcc/ada/Make-lang.in gcc-3.4.1/gcc/ada/Make-lang.in
--- gcc-3.4.1-20040625/gcc/ada/Make-lang.in	2004-06-09 05:20:41.000000000 -0400
+++ gcc-3.4.1/gcc/ada/Make-lang.in	2004-06-30 09:52:30.668619600 -0400
@@ -448,9 +448,13 @@ ada/doctools/xgnatugn$(build_exeext): ad
 	$(CP) $^ ada/doctools
 	cd ada/doctools && gnatmake -q xgnatugn
 
-doc/gnat_ugn_unw.texi : ada/doctools/xgnatugn$(build_exeext) \
-	$(srcdir)/ada/gnat_ugn.texi $(srcdir)/ada/ug_words
-	ada/doctools/xgnatugn unw $(srcdir)/ada/gnat_ugn.texi $(srcdir)/ada/ug_words doc/gnat_ugn_unw.texi
+# Note that gnat_ugn_unw.texi does not depend on xgnatugn 
+# being built so we can distribute a pregenerated gnat_ugn_unw.info
+
+doc/gnat_ugn_unw.texi: $(srcdir)/ada/gnat_ugn.texi $(srcdir)/ada/ug_words
+	$(MAKE) ada/doctools/xgnatugn$(build_exeext)
+	ada/doctools/xgnatugn unw $(srcdir)/ada/gnat_ugn.texi \
+	   $(srcdir)/ada/ug_words doc/gnat_ugn_unw.texi
 
 doc/gnat_ugn_unw.info: doc/gnat_ugn_unw.texi \
    $(docdir)/include/fdl.texi $(docdir)/include/gcc-common.texi
@@ -475,7 +479,7 @@ doc/gnat-style.info: ada/gnat-style.texi
             -I$(srcdir)/ada -o $@ $<; \
 	else true; fi
 
-ADA_INFOFILES = doc/gnat_ugn_unw.info \
+ADA_INFOFILES = doc/gnat_ugn_unw.info doc/gnat_ugn_unw.texi \
                 doc/gnat_rm.info doc/gnat-style.info
 
 ada.info: $(ADA_INFOFILES)
Comment 5 Mark Mitchell 2004-07-04 18:03:00 UTC
Subject: Re:  [3.4.1 regression] ada/doctools runs makeinfo
 even in release tarball

Kelley Cook wrote:

> This patch should fix the problem with the 3.4.1 regression that Michael
> noticed.
>
> It has been tested under 3.4 with i686-pc-cygwin by building with
> --enable-generated-files-in-srcdir
> followed by rebuilding in a clean tree from the resultant directory
> without that switch.
>
> The former case does put three ada info files into $(srcdir)/gcc/doc
> In the latter case, those same info files, as well as the xgnatugn
> executable and its generated .texi file do not get rebuilt.
>
> OK to install? 

OK for 3.4.2 when the branch reopens.

Comment 6 CVS Commits 2004-07-07 02:12:05 UTC
Subject: Bug 16250

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	kcook@gcc.gnu.org	2004-07-07 02:11:57

Modified files:
	gcc/ada        : ChangeLog Make-lang.in 

Log message:
	2004-07-07  Kelley Cook  <kcook@gcc.gnu.org>
	
	PR bootstrap/16250
	* Make-lang.in (doc/gnat_ugn_unw.texi): Eliminate explicit
	dependency on xgnatugn, instead build it via a submake.
	(ADA_INFOFILES): Add doc/gnat_ugn_unw.texi.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ada/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.428.2.10&r2=1.428.2.11
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ada/Make-lang.in.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.70.2.3&r2=1.70.2.4

Comment 7 Kelley Cook 2004-07-07 02:25:41 UTC
Due to previous checkin